Jeep Liberty 2006 - JeepForum.com
 
LinkBack Thread Tools
post #1 of 2 Old 08-01-2020, 11:35 AM Thread Starter
JFR
Registered User
 
Join Date: Sep 2009
Location: Ottawa
Posts: 4
Jeep Liberty 2006

I repaired the rust on the doors and the top of the roof on the driver's side of my Jeep Liberty 2006. When I wanted to take the jeep to my garage to paint it, it did start but it was stuck in the park. I tough it sit too long in Park. I turn off the engine and I tried to force it out of Park and now it doesnít start and it is still stuck in park. I checked everything and found nothing. The park break light are ok, the fuses are ok, I donít know what to do.

JFR is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 08-01-2020, 11:12 PM
mpmax
Registered User
 
mpmax's Avatar
2006 KJ Liberty 
 
Join Date: May 2020
Location: Woodburn
Posts: 1
There is a transmission release on the right side if the shifter, under the cover. Google it or search on this forum, I think I saw a post showing how to do it. That will get you into neutral.
mpmax is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome