06 Liberty wont crank - JeepForum.com
 
LinkBack Thread Tools
post #1 of 2 Old 02-17-2020, 07:42 AM Thread Starter
hydroferg
Registered User
2006 KJ Liberty 
 
Join Date: Feb 2020
Posts: 3
06 Liberty wont crank

2006 Liberty sport
seems like there is no power to the starter. Replaced battery and removed the starter. It tested bad at the parts store. installed new one...no clicking

hydroferg is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 02-17-2020, 10:21 AM
jtec
Web Wheeler
 
jtec's Avatar
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 7,582
be sure its in P or N .

Easy to test at relay..

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome