JeepForum.com

JeepForum.com (https://www.jeepforum.com/forum/)
-   General Jeep & Off-Road Equipment (https://www.jeepforum.com/forum/f27/)
-   -   Weird ARB Air Locker Leak (https://www.jeepforum.com/forum/f27/weird-arb-air-locker-leak-2980377/)

CherokeeGuy1998 01-28-2015 12:52 PM

Weird ARB Air Locker Leak
 
I have a very strange leak that I can't lock down. My compressor will cycle every 10-15 seconds if:
a) no lockers are engaged or
b) the rear lock is engage or
c) the front locker is engaged.

But if both lockers are engaged, absolutely no leaking at all!

I recently replaced my broken Viair gauge and thought that had been the problem all along as I could easily hear air escaping out the body. With the new one installed, no air can be heard, but the problem is just as bad as before.

I'm guessing the problem is likely in the solenoids, but I can't explain how having both engaged "fixes" the leak.

zillla 01-28-2015 02:40 PM

If the lockers are not engaged it must be leaking through the solenoid threads or just leaking by. Get a bottle of Snoop and have a look.

JeeperDon 01-28-2015 04:27 PM

I just use windex. It's incredibly handy and bubbles enough to figure things out.

wilson1010 01-28-2015 08:03 PM

My ARB front leaked from day one but only when engaged. It never got worse and tended to alert me that it is working. Same deal. Cycling every 15 seconds or so. Maybe a little longer than that.

biffgnar 01-29-2015 06:58 AM

Quote:

Originally Posted by wilson1010 (Post 28000521)
My ARB front leaked from day one but only when engaged. It never got worse and tended to alert me that it is working. Same deal. Cycling every 15 seconds or so. Maybe a little longer than that.

Doesn't that sound more like an issue in the axle (e.g. bad o-ring, nicked copper line) as engaged is the only time solenoid charging the axle? OP's issue seems likely at the solenoids since leaking when lockers not engaged.

JeeperDon 01-29-2015 07:12 AM

Quote:

Originally Posted by biffgnar (Post 28006337)
Doesn't that sound more like an issue in the axle (e.g. bad o-ring, nicked copper line) as engaged is the only time solenoid charging the axle? OP's issue seems likely at the solenoids since leaking when lockers not engaged.

Leaking when on could be anything starting at the tube connection to the solenoid on to the axle internals. Eliminate the external possibilities first. My front axle ARB was bought new in a buddies Jeep in 1997, then used to me and in my Jeep since 1999, and still has the original o-rings with no leaks. They are not necessarily prone to failure.

Indy 01-29-2015 12:14 PM

2 solenoids? My GUESS would be the solenoids themselves are leaking either internally or at the lines from the solenoids to the lockers. If they're not sealing correctly you're probably getting a little air nonstop to the lockers but not enough to engage them. With the lockers engaged you have full pressure to both lines and nowhere for the air to go until you turn them off. I'd start by checking for a good seal on both sides of the output air lines.

CherokeeGuy1998 02-05-2015 08:42 AM

Sorry it's taken me so long to get back. Thanks for all of the suggestions.

It was one of the solenoids. I left the engine off, ran the compressor, and I could hear air escaping. I felt around the solenoids and found a strong blast of air coming out the top of one of the solenoids. The black plastic bodies of these solenoids have a hole machined into the top of them to release the air when the locker is disengaged and this is where the air is escaping. I probably have a bad O-ring that needs replacing.

Thanks again for everyone's input.


The time now is 08:32 AM.

Powered by vBulletin Version 3.8.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.