Wife's WK build. Sorta - JeepForum.com
Reply
 
LinkBack Thread Tools
post #1 of 25 Old 02-23-2018, 09:31 PM Thread Starter
sampuppy1
Registered User
1936 CJ2A 
 
Join Date: Sep 2017
Location: Wayland
Posts: 105
Wife's WK build. Sorta

This thing is going to stay relatively stock or at the very most, mild. I'll eventually use it for a daily when she feels like upgrading.

This is an 08 WK CRD. Laredo trim. Loaded. It had just shy of 150k I think when we got it. Just had glow plugs and all EGR stuff addressed before we purchased it which was great because I have plans to tune all that out and now that it's new, I won't be hard pressed to get it done because it won't be the cause of troubles for a little while at least.

First off was to get the thing detailed inside and out. It wasnt pretty. Still isn't perfect. Needs a few things on the outside but the inside is in great shape. It got a good hand wash, a hard cut compound and a coat of wax. It shined up really well for what it is.

Sent from my XT1635-01 using Tapatalk

Tyler/T-Unit

sampuppy1 is offline  
Sponsored Links
Advertisement
 
post #2 of 25 Old 02-23-2018, 09:39 PM Thread Starter
sampuppy1
Registered User
1936 CJ2A 
 
Join Date: Sep 2017
Location: Wayland
Posts: 105
Next up was to address the horrible road noise. It has a set of nearly new BFG All Terrain TA KO2s so those play a big part in it. The other culprit was the original struts and shocks.

Ordered a set of bilsteins for it. Thought for sure I had requested 4600s. The wife picked them up and when I got home and opened the boxes.......I found 5100s. That would explain the abnormally high price (I figured it was just because of the guy I ordered them through)

After finding they would work on a stock Jeep, I got to installing them. At the middle setting the struts picked the front up right to level which is awesome! They look pretty dang neat up under there too.

Sent from my XT1635-01 using Tapatalk

Tyler/T-Unit
sampuppy1 is offline  
post #3 of 25 Old 02-23-2018, 09:45 PM
NYGLT56
Your Local Body Builder
 
NYGLT56's Avatar
2003 TJ Wrangler 
 
Join Date: Jan 2010
Location: Rio Rancho
Posts: 2,075
Garage
Nice! Welcome to the CRD Family.


2014 TJOTY Winner

IG: theracingjeep

Daily Driven Lowrider Adventure TJ on 40s.

2014 TJOTY Winner
IG: theracingjeep
SAS CRD WK on 37s
Lowrider TJ on 40s
NYGLT56 is offline  
 
post #4 of 25 Old 02-23-2018, 09:56 PM Thread Starter
sampuppy1
Registered User
1936 CJ2A 
 
Join Date: Sep 2017
Location: Wayland
Posts: 105
Started getting a "mods" list put together in the order of necessity.

1. GDE hot tune
2. EHM
3. DPF delete
4. Headlight housings
5. Fog lights
6. LED tails


On the repairs list in no particular order
1. New stock bumper/grille. Just needs it because one of the previous owners appears to have thoroughly tested the "trail rated" badge on the fenders. Lower splash Shields and valence are long gone, front inner wheel wells are busted all to hell. Grille is missing an insert, and one fog light is gone and the hole is blown out for it.
2. Injector seal(s) the right front is clearly leaking and needs addressed.
3. Cargo hatch interior light is MIA
4. Couple of the speakers seem to be out.
5. It seems the air filter to turbo inlet tube is in rough shape. The plastic on the turbo end is all busted up and the seals for the PCV inlet and turbo inlet are all gross and stuff.
6. A/C condenser has a tear at the bottom so I'll need to get a new one

Sent from my XT1635-01 using Tapatalk

Tyler/T-Unit
sampuppy1 is offline  
post #5 of 25 Old 02-25-2018, 06:26 PM
rrxjeeper71
Registered User
 
rrxjeeper71's Avatar
2004 WJ 
 
Join Date: Sep 2013
Location: round rock
Posts: 147
any new mods?

2001 XJ Sport
3.5 RC lift
31" BFG
rrxjeeper71 is offline  
post #6 of 25 Old 02-25-2018, 11:55 PM Thread Starter
sampuppy1
Registered User
1936 CJ2A 
 
Join Date: Sep 2017
Location: Wayland
Posts: 105
Not yet. I gotta get back to work before I can start changing anything. Right now it's maintenance only. I'm trying to get out of seasonal work so I have mod money all year.

Sent from my XT1635-01 using Tapatalk

Tyler/T-Unit
sampuppy1 is offline  
post #7 of 25 Old 02-28-2018, 11:30 PM Thread Starter
sampuppy1
Registered User
1936 CJ2A 
 
Join Date: Sep 2017
Location: Wayland
Posts: 105
Injector seals done. The black death was so deep up front it was actually spilling out over the valve cover bolts. I chipped out as much as I could get to with my trusty picks and screw drivers. I pulled the center injector since it was surrounded by black death and I wanted to make sure that seal wasn't leaking and adding to the nasty mess. Of course that seal was fine. But the injector was slathered in anti-seize. So I had to suck a ton of that out of the hole as it has pooled at the bottom after removing it.

I found decent work so I should have a hot tune in order here within a month or two. I'll be looking into some hose for the EHM in the next week or two as well as getting a new turbo intake hose and the block off plug. I'm actually quite excited to get this rolling. I'm a diesel nut and even though this is the wife's daily, I still get to build on it and make it a respectable daily for her and something she can be proud of. She never helps much with Auto stuff. It's pretty much my thing. But she helped me cut and buff it and she's cleaned it out a few times already. She never did that with her previous vehicles. She just drove them and let me know when they needed service or repair. Never really washed or detailed them.

Sent from my XT1635-01 using Tapatalk

Tyler/T-Unit
sampuppy1 is offline  
post #8 of 25 Old 03-25-2018, 03:19 AM Thread Starter
sampuppy1
Registered User
1936 CJ2A 
 
Join Date: Sep 2017
Location: Wayland
Posts: 105
Got everything for the EHM. Should have it done tomorrow. Just venting to atmosphere.

GDE hot tune should also be on the shopping list as soon as the tax return hits. I'm excited. Just a few more little touches and this Jeep should be in ship shape again. Will definitely need to look into an a/c condenser very soon. It's fixing to get hot out soon and it also needs tint.

Sent from my XT1635-01 using Tapatalk

Tyler/T-Unit
sampuppy1 is offline  
post #9 of 25 Old 04-08-2018, 12:36 PM Thread Starter
sampuppy1
Registered User
1936 CJ2A 
 
Join Date: Sep 2017
Location: Wayland
Posts: 105
EHM is done! The weather has not been cooperating and the jeep has been getting used all day every day it seems like, so I haven't had a chance to really dig into it. Looks like I need to find an intercooler as well and I'll do that and the condenser at the same time.

I did finally get some proper LEDs in the reverse lights. These are Sylvania Zevos.

Sent from my XT1635-01 using Tapatalk

Tyler/T-Unit
sampuppy1 is offline  
post #10 of 25 Old 04-15-2018, 09:14 AM Thread Starter
sampuppy1
Registered User
1936 CJ2A 
 
Join Date: Sep 2017
Location: Wayland
Posts: 105
I'm planning to order the GDE hot tune this coming week. I'm pretty excited. Even though I'm not really going to be the one enjoying the benefits.

Sent from my XT1635-01 using Tapatalk

Tyler/T-Unit
sampuppy1 is offline  
post #11 of 25 Old 05-11-2018, 07:51 PM Thread Starter
sampuppy1
Registered User
1936 CJ2A 
 
Join Date: Sep 2017
Location: Wayland
Posts: 105
The dreaded red lightning bolt ETC light came on today and a no start condition. Eventually started but light stayed on. Time to take a trip down to the vatozone to see what codes were stored.

Sent from my XT1635-01 using Tapatalk

Tyler/T-Unit
sampuppy1 is offline  
post #12 of 25 Old 07-02-2018, 06:44 PM Thread Starter
sampuppy1
Registered User
1936 CJ2A 
 
Join Date: Sep 2017
Location: Wayland
Posts: 105
Does the ETC light store codes? So far i haven't had any pop up. Haven't caught it with the light on yet. It's intermittent and there's no pattern to when it comes on or derates.

Sent from my XT1635-01 using Tapatalk

Tyler/T-Unit
sampuppy1 is offline  
post #13 of 25 Old 07-02-2018, 09:54 PM Thread Starter
sampuppy1
Registered User
1936 CJ2A 
 
Join Date: Sep 2017
Location: Wayland
Posts: 105
Check engine light was lit this time. Code pulled was a p0299. Underboost.

I had full power and boost on my way to get the code yanked.

I was able to get it to act up this time as well. On my way back from vatozone, the ETC light started flashing, went into limp. Wouldn't spool the turbo


Sent from my XT1635-01 using Tapatalk

Tyler/T-Unit
sampuppy1 is offline  
post #14 of 25 Old 08-09-2018, 06:16 AM Thread Starter
sampuppy1
Registered User
1936 CJ2A 
 
Join Date: Sep 2017
Location: Wayland
Posts: 105
Hot to the dealer finally to have it looked into. Took all of maybe 15 mins to determine that the actuator for the turbo is most definitely the responsible party here. Luckily I didn't get charged for the codes list or a diagnostic fee. The head tech was super cool and let me pick his brain over it and explain a little about how the systems talk to each other. So now I'm on the hunt for an actuator. Looking into this

Turbo Electric Actuator For Mercedes Sprinter Grand Cherokee GL350/320 G-001 6NW009660 https://www.amazon.com/dp/B075WT2D58..._qU5ABb0146804

Sent from my XT1635-01 using Tapatalk

Tyler/T-Unit
sampuppy1 is offline  
post #15 of 25 Old 08-11-2018, 10:47 AM
Damo O'Neill
Registered User
 
Join Date: Aug 2018
Posts: 1
Gday mate. Just a heads up, that turbo-actuator problem can almost certainly be sorted with a few well directed prods of a soldering iron and 2 fly farts worth of fresh solder. Ask me how i know

The hardest part from memory was aligning the bolts that go through the actuator to secure it back into position. If you are taking the old one out to put a new one in, it only takes an extra 1/2hr to pry the metal jesus-clips off your old actuator to separate the cast metal from plastic.....then just re-solder the circuit board connections on the edge where the pins for the external connectors attach. Whack the cover and clips back on, then reinstall and bolt her all back together.

Repair vs replace.....its up to you bud, but if you can think of anything....anything at all you'd prefer to spend the 140$ on and still get the exact same result, its worth considering
Cheers
Damo O'Neill is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome