CJ7 Too Loud - JeepForum.com
 
LinkBack Thread Tools
post #1 of 1 Old 06-11-2021, 10:36 AM Thread Starter
LJB
Registered User
 
Join Date: May 2021
Posts: 3
CJ7 Too Loud

I recently purchased a 1980 CJ7 with an inline 6 cylinder and manual trans.Previous owners did a fair amount of work under the hood : rebuilt engine and trans etc. The catylitic converter (on a 1980) has likely been removed . Engine exhaust is what looks like two (generic looking) headers each 3 pipes funneling into two 2.5 inch pipes going to a “manga flow” muffler (no model number) and two, 2.5 inch pipes coming straight out of muffler on the driver’s side rear of Jeep.See attached files. The exhaust is way too loud for my liking, I would rather be seen than heard. I’m in Texas. Some recommendations have been, replace catylitic converter, stock muffler and resonator. I’m not too interested in replacing converter (ranch running). Suggestions in quieting exhaust much appreciated. Muffler type and model ?

Attached Thumbnails
48646F86-89AD-4719-9B6E-3BA118B269D9.jpg   695EA8B2-CD12-4B67-84A6-496E8EE34353.jpg  

LB
LJB is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome