YJ Instrument cluster problems - JeepForum.com
 
LinkBack Thread Tools
post #1 of 2 Old 09-20-2019, 06:50 PM Thread Starter
Perazzi
Registered User
1993 YJ Wrangler 
 
Join Date: Sep 2019
Posts: 1
Yj YJ Instrument cluster problems

I need some advice.
All of my instrument cluster indicators are either not working or are way off (like my gas gauge). Also my speedometer is working only part time and randomly at that. Any suggestions as to if there is a fix for this or do I have to replace all of them.
Thanks in advance.
Ben

Perazzi is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 10-31-2019, 01:20 AM
CSpeade51
Registered User
 
Join Date: Oct 2019
Location: Virginia Beach
Posts: 11
Garage
Did this randomly start happening? or has it steadily gone out. The best place with electrical is the grounds. lift them clean them up and replace. fuses and connections. the older YJs are cable driven for the speedo IIRC and that is probably a mechanical failure.
CSpeade51 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome