LED turn signals not working - JeepForum.com
 
LinkBack Thread Tools
post #1 of 2 Old 07-27-2014, 02:50 PM Thread Starter
Klinestine
Registered User
2002 TJ Wrangler 
 
Join Date: Mar 2014
Location: Annapolis
Posts: 12
LED turn signals not working

I've looked everywhere and cannot seem to find anyone with a similar issue. I just installed the Metalcloak Overlines on my TJ. I installed the LED lights as instructed and have hit a wall. No matter which way I match up the wires, I cannot get my turn signals to work. The hazards, running and front lights all work just fine.

I tired the trick I saw about turning on the hazards and then switching to your turn signals, but that only works for a flash or two and then nothing. I have no clue what's stopping them. Help???

I've switched the wires, tried running it with the engine off and on, used both the designated LED and original relay, and replaced the fuses. All to no avail.

Klinestine is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 08-04-2014, 09:54 PM
R32Smith
Registered User
2005 LJ Wrangler 
 
Join Date: Feb 2012
Location: San Diego
Posts: 21
I would call MetalCloak and see if tech support can help. Normally LED's will require a load resistor or LED Relay. Since you say you already swapped things around with the relay, maybe you got a bad set of lights.
R32Smith is offline  
Reply

Tags
head light , headlight , led , metal cloak , metalcloak

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome