HID Issues - JeepForum.com
 
LinkBack Thread Tools
post #1 of 1 Old 12-30-2014, 07:04 PM Thread Starter
jhjr85
Registered User
 
Join Date: Nov 2011
Posts: 3
HID Issues

I have a 05 grand Cherokee laredo that I put in HID's that I got from ebay. I just have the bulbs and ballast, no relay. Here's my issue

When I unlock car, lights come on, great, but if I dont start the car in time, or if I dont have it on Auto the lights will shut off and won't come back on. This is fine in the day time, but kind of embarrassing at night when I have to pop the hood and disconnect and then reconnect the bulbs in order for them to come back on. Also had to pull off the road before because it got dark before I got home.

My question is if a relay will fix the problem? and if so, one with or without resistors? I asked some of the ebay sellers and they give me mixed answers. I know its cheap kit from ebay, but they worked fine and never gave me any issues when I had them in my old explorer.
Thought about making all 3 sets (fog, low, and Hi) HID... but I tried the hi-beams and they do the same thing, once I use them once, they dont come back on again.

Any suggestions, and no Im not buying a 100 kit

jhjr85 is offline  
Reply

Tags
hid , light , relays

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome