79 Jeep J10 not getting power - JeepForum.com
 
LinkBack Thread Tools
post #1 of 1 Old 10-12-2019, 02:24 PM Thread Starter
Huntvinc
Registered User
 
Join Date: Oct 2019
Posts: 1
79 Jeep J10 not getting power

I recently acquired my grandfathers 79 Jeep J10 and have begun the restoration process (first timer). My dad had the truck running 6-7 years ago but it’s been in storage ever since. I started with all the basic tune up stuff. Cleaned out fuel tank, repaired lines, all new filters, oil, brakes, plugs, wires, battery, new fuel pump, etc and it fired right up and ran great. My dad mentioned that he thought it has a wiring issue that would drain the battery after sitting for a few weeks. I cranked it several times this week with no issue, but on Thursday I went to crank it and it started to crank for a split second and then lost all power. Not the air, dash lights, or anything will come on when I turn the key now. Radio does light up when I turn it backward. I removed the battery and charged it for 24 hours and still nothing. Not sure what all needs to be checked or what it could be. Any help on where to start will be greatly appreciated. Thanks!

Huntvinc is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome