1988 Comanche Fuse block has no power, No Blinkers, Wipers, Tail lights, stereo... - JeepForum.com
 
LinkBack Thread Tools
post #1 of 1 Old 12-03-2015, 02:16 PM Thread Starter
davidpk52
Registered User
1988 MJ Comanche 
 
Join Date: Dec 2015
Location: larkspur
Posts: 3
1988 Comanche Fuse block has no power, No Blinkers, Wipers, Tail lights, stereo...

Hi I just bought a Comanche that I have been looking for a while to find and wanted make sure it was the right one. last it was registered was 6 years ago but runs great and has been taking care of, although I feel like non of the fuses coming underneath the steering wheel look fine but none of the things are getting power, no wipers, blinkers, tail lights and almost everything that has a fuse for it, the fuses are fine its just like not getting power to all of them. I did see a red wire that was added to the fuse box that was cut and led no where, maybe used for lights or something. Please any kind of help would be much appreciated

davidpk52 is offline  
Reply

Tags
blinkers , comanche , electrical issue , fuse block

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome