Snobrdrkid's WJ Build Thread - Page 443 - JeepForum.com
Reply
 
LinkBack Thread Tools
post #6631 of 6789 Old 08-28-2014, 10:57 AM
ChrisHager
Administrator
 
ChrisHager's Avatar
2004 WJ 
 
Join Date: Jan 2011
Location: Springfield
Posts: 10,561
Garage
Quote:
Originally Posted by snobrdrkid07 View Post
Few things to update with the WJ. 300 miles in about 5 hours, between 55 and 70 mph cruising, loaded, averaged about 18.4 hand calculated. No issues to really report just had one bridge that really upset it and made the Jeep shimmy for a couple seconds. Tires are riding smooth, quiet, and show little wear. I need to rotate them, its been 6700 miles.
I just did a 425 mile round trip down to Missouri for a little camping and canoeing. On the run there, we averaged about 15 mpg. The drive home plus a little in town hit me at 13.5. I'd be pumped to have 18.4!

Quote:
Originally Posted by snobrdrkid07 View Post
In other news I have been ordering a lot of parts for the Rubicon.
- OME HD's, we've got bumpers front and rear with a the winch
- Bilstein 5100's
- OME Rear TB Bracket
- Moog STB SS
- Undercover Fab "Extra Clearence" skid 1/4" steel with Air Pump bracket
- Lo Pro Trans mount so we can use the Extra Clearence skid with no body lift.

Next up hopefully will be some Control arms, JKS Disco's, and 33" Kevlar MT/R's
That's a pretty good list! You should start a build thread...


~Chris
His: 2004 WJ - OME HD 'Kolak' Lift -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

His: 1979 J-10 - 3" on 33s -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

His: 2009 Expedition
His: 1978 F250 Custom -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Hers: 2000 TJ
Hers: 2010 Jetta


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Quote:
Originally Posted by Matt
"You can't recycle tartar sauce."
Quote:
Originally Posted by steve_80 View Post
Weird, I didn't realize you could use vomit as coolant.
ChrisHager is offline  
Sponsored Links
Advertisement
 
post #6632 of 6789 Old 09-01-2014, 09:32 AM Thread Starter
snobrdrkid07
Web Wheeler
 
snobrdrkid07's Avatar
2004 WJ 
 
Join Date: Jul 2010
Location: Chesapeake/Blacksburg
Posts: 8,851
Garage
Rotated the tires finally. Checked the ball joints and only noticed a small amount of movement on the pass side upper. Next up is the UCA's, maybe. Then I gotta get the transmission fluid done at some point.

Hooked up the air locker to my friends TJ's. Swapped in a Rubi 44.

~ 04 WJ Overland 4.7 HO | Graphite Metallic | Quadra-Drive | Vari-Locks | Bilstein 4600ís | ADDCO Sway Bar | Powerstick Exhaust | RB1 | SuperChips Tuned | Much More to Come ~

~ 04 WJ Laredo 4.0 | Selec-Trac | MBP | OME HD 3" Lift | JKS TB | IRO Front LCA's and UCA's| Bilstein 5100's | Silent Armor 245/70/17's | Custom Front D.S. | Stillen Rotors/Pads | Tow Package w/ 3.73's | Moog HD Steering | Kenwood eXcelon HU | Alpine Speakers, Amps, and Subs | Bilstein SS | Auxiliary Transmission Cooler | Rock Lights | Light Bars | Lots of Cool Stuff ~

~ 05 Rubicon Unlimited 4.0 | 6-Speed | Dana 44's | Air Lockers | 4.11 Gears | Rock-Trac 241OR T-Case with 4:1 4-Low | OME HD Springs | Bilstein 5100ís | 245/75/16 Kevlar MT/R's on Moabs | Hansen Offroad Steel F/R Bumpers | Warn 9000xi Winch | Edge Performance Chip | Custom CAI | Hella Off-road Lights | Cobra 29 CB | Flash Lights | Recovery Gear | Fire Extinguisher ~

~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~



-Michael-
snobrdrkid07 is offline  
post #6633 of 6789 Old 09-01-2014, 09:41 AM
ChrisHager
Administrator
 
ChrisHager's Avatar
2004 WJ 
 
Join Date: Jan 2011
Location: Springfield
Posts: 10,561
Garage
Quote:
Originally Posted by snobrdrkid07 View Post
Rotated the tires finally. Checked the ball joints and only noticed a small amount of movement on the pass side upper. Next up is the UCA's, maybe. Then I gotta get the transmission fluid done at some point.

Hooked up the air locker to my friends TJ's. Swapped in a Rubi 44.
Sounds like fun!

~Chris
His: 2004 WJ - OME HD 'Kolak' Lift -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

His: 1979 J-10 - 3" on 33s -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

His: 2009 Expedition
His: 1978 F250 Custom -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Hers: 2000 TJ
Hers: 2010 Jetta


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Quote:
Originally Posted by Matt
"You can't recycle tartar sauce."
Quote:
Originally Posted by steve_80 View Post
Weird, I didn't realize you could use vomit as coolant.
ChrisHager is offline  
 
post #6634 of 6789 Old 09-08-2014, 09:53 AM Thread Starter
snobrdrkid07
Web Wheeler
 
snobrdrkid07's Avatar
2004 WJ 
 
Join Date: Jul 2010
Location: Chesapeake/Blacksburg
Posts: 8,851
Garage
Took the WJ up with the club for some light wheeling. Fire Roads, mud, and some small rocks. All was great until I notice this morning, fluid...

Looks like it came from the steering box and shot back from there to the ABS pump area. Covered the hood liner and splashed the air box and air box cover. Hard to tell a color but it was a reddish tint. However what it getting me is that nothing is dripping, gushing fluid, and everything still works. It was like a temporary "spurt". I ran the Jeep in N in the parking lot and looked for ATF to drip and nothing. Maybe its the HP PS Line and only blows fluid under high pressure? Noting that the HP PS line has been "wet" and would make the occasional drip at the bottom.
Attached Thumbnails
10636131_10204645199516062_7486262776458348722_n.jpg  
Attached Images
 

~ 04 WJ Overland 4.7 HO | Graphite Metallic | Quadra-Drive | Vari-Locks | Bilstein 4600ís | ADDCO Sway Bar | Powerstick Exhaust | RB1 | SuperChips Tuned | Much More to Come ~

~ 04 WJ Laredo 4.0 | Selec-Trac | MBP | OME HD 3" Lift | JKS TB | IRO Front LCA's and UCA's| Bilstein 5100's | Silent Armor 245/70/17's | Custom Front D.S. | Stillen Rotors/Pads | Tow Package w/ 3.73's | Moog HD Steering | Kenwood eXcelon HU | Alpine Speakers, Amps, and Subs | Bilstein SS | Auxiliary Transmission Cooler | Rock Lights | Light Bars | Lots of Cool Stuff ~

~ 05 Rubicon Unlimited 4.0 | 6-Speed | Dana 44's | Air Lockers | 4.11 Gears | Rock-Trac 241OR T-Case with 4:1 4-Low | OME HD Springs | Bilstein 5100ís | 245/75/16 Kevlar MT/R's on Moabs | Hansen Offroad Steel F/R Bumpers | Warn 9000xi Winch | Edge Performance Chip | Custom CAI | Hella Off-road Lights | Cobra 29 CB | Flash Lights | Recovery Gear | Fire Extinguisher ~

~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~



-Michael-
snobrdrkid07 is offline  
post #6635 of 6789 Old 09-08-2014, 12:31 PM
billzcat1
Chicken in a Turkey Suit
2003 WJ 
 
Join Date: Oct 2008
Location: Redmond
Posts: 8,534
When my HP line went, it would only leak when it *wasn't* pressurized. The leak was at the fitting going into the pump. Under pressure it closed the leak, when cooling down the fitting opened up and dripped like crazy. Yours looks like it is getting to the pulley, hence the spray everywhere. Double check that you aren't lubricating your serpentine belt.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


~Richard
billzcat1 is offline  
post #6636 of 6789 Old 09-08-2014, 01:28 PM Thread Starter
snobrdrkid07
Web Wheeler
 
snobrdrkid07's Avatar
2004 WJ 
 
Join Date: Jul 2010
Location: Chesapeake/Blacksburg
Posts: 8,851
Garage
Took a look at all the PS fittings, dry.




A closer look revealed fluid on the radiator and the aux cooler. you can see the fluid stain, darker color, on the aux cooler.



You can see fluid film all on the AC condensor and Rad



So I start thinking I blew the aux cooler some how... not cool. Hah pun. Then I see this...



Must have popped the hose clamp and while wheeling trans must have gotten real hot and gotten past the hose and barb fitting... I hope that is the case and it is just an easy fix.

Got everywhere, on the support and melted the rubber hook gasket thing



Probably got INTO the air intake based on the leak location, air intake, and fluid around the joint...



Anyone have a reason why fluid snuck passed and didn't blow the line off. Or why it isn't leaking a whole lot currently?

~ 04 WJ Overland 4.7 HO | Graphite Metallic | Quadra-Drive | Vari-Locks | Bilstein 4600ís | ADDCO Sway Bar | Powerstick Exhaust | RB1 | SuperChips Tuned | Much More to Come ~

~ 04 WJ Laredo 4.0 | Selec-Trac | MBP | OME HD 3" Lift | JKS TB | IRO Front LCA's and UCA's| Bilstein 5100's | Silent Armor 245/70/17's | Custom Front D.S. | Stillen Rotors/Pads | Tow Package w/ 3.73's | Moog HD Steering | Kenwood eXcelon HU | Alpine Speakers, Amps, and Subs | Bilstein SS | Auxiliary Transmission Cooler | Rock Lights | Light Bars | Lots of Cool Stuff ~

~ 05 Rubicon Unlimited 4.0 | 6-Speed | Dana 44's | Air Lockers | 4.11 Gears | Rock-Trac 241OR T-Case with 4:1 4-Low | OME HD Springs | Bilstein 5100ís | 245/75/16 Kevlar MT/R's on Moabs | Hansen Offroad Steel F/R Bumpers | Warn 9000xi Winch | Edge Performance Chip | Custom CAI | Hella Off-road Lights | Cobra 29 CB | Flash Lights | Recovery Gear | Fire Extinguisher ~

~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~



-Michael-
snobrdrkid07 is offline  
post #6637 of 6789 Old 09-08-2014, 02:33 PM
billzcat1
Chicken in a Turkey Suit
2003 WJ 
 
Join Date: Oct 2008
Location: Redmond
Posts: 8,534
You might have a pinhole leak where the clamp was. Over-tightened clamps can cut the rubber hoses. If you have enough hose, snip off the last 1" of the hose and throw a new clamp on there and see what happens.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


~Richard
billzcat1 is offline  
post #6638 of 6789 Old 09-08-2014, 02:37 PM Thread Starter
snobrdrkid07
Web Wheeler
 
snobrdrkid07's Avatar
2004 WJ 
 
Join Date: Jul 2010
Location: Chesapeake/Blacksburg
Posts: 8,851
Garage
Must have put one to many turns on it back in the day. Was thinking the same, cutting off a bit hose and then reclamping. Going to get some degreaser and hit the whole area so I can spot leaks if the re-occur. Probably should get fluid levels too. With the clamp broken, I'd say that has got to be where the fluid came from. Fingers crossed the cooler itself isn't broken.

~ 04 WJ Overland 4.7 HO | Graphite Metallic | Quadra-Drive | Vari-Locks | Bilstein 4600ís | ADDCO Sway Bar | Powerstick Exhaust | RB1 | SuperChips Tuned | Much More to Come ~

~ 04 WJ Laredo 4.0 | Selec-Trac | MBP | OME HD 3" Lift | JKS TB | IRO Front LCA's and UCA's| Bilstein 5100's | Silent Armor 245/70/17's | Custom Front D.S. | Stillen Rotors/Pads | Tow Package w/ 3.73's | Moog HD Steering | Kenwood eXcelon HU | Alpine Speakers, Amps, and Subs | Bilstein SS | Auxiliary Transmission Cooler | Rock Lights | Light Bars | Lots of Cool Stuff ~

~ 05 Rubicon Unlimited 4.0 | 6-Speed | Dana 44's | Air Lockers | 4.11 Gears | Rock-Trac 241OR T-Case with 4:1 4-Low | OME HD Springs | Bilstein 5100ís | 245/75/16 Kevlar MT/R's on Moabs | Hansen Offroad Steel F/R Bumpers | Warn 9000xi Winch | Edge Performance Chip | Custom CAI | Hella Off-road Lights | Cobra 29 CB | Flash Lights | Recovery Gear | Fire Extinguisher ~

~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~



-Michael-
snobrdrkid07 is offline  
post #6639 of 6789 Old 09-09-2014, 02:44 PM
ChrisHager
Administrator
 
ChrisHager's Avatar
2004 WJ 
 
Join Date: Jan 2011
Location: Springfield
Posts: 10,561
Garage
Quote:
Originally Posted by billzcat1 View Post
You might have a pinhole leak where the clamp was. Over-tightened clamps can cut the rubber hoses. If you have enough hose, snip off the last 1" of the hose and throw a new clamp on there and see what happens.
I had a transmission hose do just that:


~Chris
His: 2004 WJ - OME HD 'Kolak' Lift -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

His: 1979 J-10 - 3" on 33s -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

His: 2009 Expedition
His: 1978 F250 Custom -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Hers: 2000 TJ
Hers: 2010 Jetta


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Quote:
Originally Posted by Matt
"You can't recycle tartar sauce."
Quote:
Originally Posted by steve_80 View Post
Weird, I didn't realize you could use vomit as coolant.
ChrisHager is offline  
post #6640 of 6789 Old 09-09-2014, 03:00 PM Thread Starter
snobrdrkid07
Web Wheeler
 
snobrdrkid07's Avatar
2004 WJ 
 
Join Date: Jul 2010
Location: Chesapeake/Blacksburg
Posts: 8,851
Garage
Yikes. I didn't see anything cut in my hose however, I slid more hose onto the barb and put the hose clamp further back to where the original clamp was. I wasn't able to pull the line off so I just slid it on more. I did not want to budge on or off. I would have to pull off the header panel or undo the lines at the original cooler barbs in order to yank out the aux cooler to get to a better spot to work on it. It is real tight between the header panel, etc. If it goes again, I'll put in new line and tear it all down... Fingers crossed that won't be needed.

~ 04 WJ Overland 4.7 HO | Graphite Metallic | Quadra-Drive | Vari-Locks | Bilstein 4600ís | ADDCO Sway Bar | Powerstick Exhaust | RB1 | SuperChips Tuned | Much More to Come ~

~ 04 WJ Laredo 4.0 | Selec-Trac | MBP | OME HD 3" Lift | JKS TB | IRO Front LCA's and UCA's| Bilstein 5100's | Silent Armor 245/70/17's | Custom Front D.S. | Stillen Rotors/Pads | Tow Package w/ 3.73's | Moog HD Steering | Kenwood eXcelon HU | Alpine Speakers, Amps, and Subs | Bilstein SS | Auxiliary Transmission Cooler | Rock Lights | Light Bars | Lots of Cool Stuff ~

~ 05 Rubicon Unlimited 4.0 | 6-Speed | Dana 44's | Air Lockers | 4.11 Gears | Rock-Trac 241OR T-Case with 4:1 4-Low | OME HD Springs | Bilstein 5100ís | 245/75/16 Kevlar MT/R's on Moabs | Hansen Offroad Steel F/R Bumpers | Warn 9000xi Winch | Edge Performance Chip | Custom CAI | Hella Off-road Lights | Cobra 29 CB | Flash Lights | Recovery Gear | Fire Extinguisher ~

~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~



-Michael-
snobrdrkid07 is offline  
post #6641 of 6789 Old 09-14-2014, 02:42 PM Thread Starter
snobrdrkid07
Web Wheeler
 
snobrdrkid07's Avatar
2004 WJ 
 
Join Date: Jul 2010
Location: Chesapeake/Blacksburg
Posts: 8,851
Garage
Weekend wrap up:
Trans line is still holding without leaks. *fingers crosses*

FINALLY got the IRO UCA's installed. Nine Months after I bought them...

Old bushings were not in the best shape...




~ 04 WJ Overland 4.7 HO | Graphite Metallic | Quadra-Drive | Vari-Locks | Bilstein 4600ís | ADDCO Sway Bar | Powerstick Exhaust | RB1 | SuperChips Tuned | Much More to Come ~

~ 04 WJ Laredo 4.0 | Selec-Trac | MBP | OME HD 3" Lift | JKS TB | IRO Front LCA's and UCA's| Bilstein 5100's | Silent Armor 245/70/17's | Custom Front D.S. | Stillen Rotors/Pads | Tow Package w/ 3.73's | Moog HD Steering | Kenwood eXcelon HU | Alpine Speakers, Amps, and Subs | Bilstein SS | Auxiliary Transmission Cooler | Rock Lights | Light Bars | Lots of Cool Stuff ~

~ 05 Rubicon Unlimited 4.0 | 6-Speed | Dana 44's | Air Lockers | 4.11 Gears | Rock-Trac 241OR T-Case with 4:1 4-Low | OME HD Springs | Bilstein 5100ís | 245/75/16 Kevlar MT/R's on Moabs | Hansen Offroad Steel F/R Bumpers | Warn 9000xi Winch | Edge Performance Chip | Custom CAI | Hella Off-road Lights | Cobra 29 CB | Flash Lights | Recovery Gear | Fire Extinguisher ~

~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~



-Michael-
snobrdrkid07 is offline  
post #6642 of 6789 Old 09-24-2014, 12:08 PM Thread Starter
snobrdrkid07
Web Wheeler
 
snobrdrkid07's Avatar
2004 WJ 
 
Join Date: Jul 2010
Location: Chesapeake/Blacksburg
Posts: 8,851
Garage
Been running well lately. Just a few annoying quirks.

Steering wheel is popping while applying up and down pressure and over bumps. Annoying.

https://www.youtube.com/watch?v=FeBRFSK0GPU

There is a real odd clunking thumping coming from the passenger side footwell area.

https://www.youtube.com/watch?v=Zl2fPCcB0FA

No idea what is causing either of those annoyances.

Lastly does anyone have a recommendation for ball joints, I was thinking Moog, Spicer, or Alloy USA.


Edit: Fixed Links

~ 04 WJ Overland 4.7 HO | Graphite Metallic | Quadra-Drive | Vari-Locks | Bilstein 4600ís | ADDCO Sway Bar | Powerstick Exhaust | RB1 | SuperChips Tuned | Much More to Come ~

~ 04 WJ Laredo 4.0 | Selec-Trac | MBP | OME HD 3" Lift | JKS TB | IRO Front LCA's and UCA's| Bilstein 5100's | Silent Armor 245/70/17's | Custom Front D.S. | Stillen Rotors/Pads | Tow Package w/ 3.73's | Moog HD Steering | Kenwood eXcelon HU | Alpine Speakers, Amps, and Subs | Bilstein SS | Auxiliary Transmission Cooler | Rock Lights | Light Bars | Lots of Cool Stuff ~

~ 05 Rubicon Unlimited 4.0 | 6-Speed | Dana 44's | Air Lockers | 4.11 Gears | Rock-Trac 241OR T-Case with 4:1 4-Low | OME HD Springs | Bilstein 5100ís | 245/75/16 Kevlar MT/R's on Moabs | Hansen Offroad Steel F/R Bumpers | Warn 9000xi Winch | Edge Performance Chip | Custom CAI | Hella Off-road Lights | Cobra 29 CB | Flash Lights | Recovery Gear | Fire Extinguisher ~

~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~



-Michael-
snobrdrkid07 is offline  
post #6643 of 6789 Old 10-09-2014, 01:31 PM Thread Starter
snobrdrkid07
Web Wheeler
 
snobrdrkid07's Avatar
2004 WJ 
 
Join Date: Jul 2010
Location: Chesapeake/Blacksburg
Posts: 8,851
Garage
Fixed the steering wheel clunk by tightening the crap out of the 4 bolts that hold the steering wheel column to the dash.

FINALLY bit the bullet and bought some parts:
4 Spicer Ball Joints
2 SKF Wheel Bearings
2 Nothing special Rear Rotors
2 New rear LCA's
6 Quarts of ATF
1 Mopar Transmission Filter.

Amazon is a great site, and all of that was on Prime.

~ 04 WJ Overland 4.7 HO | Graphite Metallic | Quadra-Drive | Vari-Locks | Bilstein 4600ís | ADDCO Sway Bar | Powerstick Exhaust | RB1 | SuperChips Tuned | Much More to Come ~

~ 04 WJ Laredo 4.0 | Selec-Trac | MBP | OME HD 3" Lift | JKS TB | IRO Front LCA's and UCA's| Bilstein 5100's | Silent Armor 245/70/17's | Custom Front D.S. | Stillen Rotors/Pads | Tow Package w/ 3.73's | Moog HD Steering | Kenwood eXcelon HU | Alpine Speakers, Amps, and Subs | Bilstein SS | Auxiliary Transmission Cooler | Rock Lights | Light Bars | Lots of Cool Stuff ~

~ 05 Rubicon Unlimited 4.0 | 6-Speed | Dana 44's | Air Lockers | 4.11 Gears | Rock-Trac 241OR T-Case with 4:1 4-Low | OME HD Springs | Bilstein 5100ís | 245/75/16 Kevlar MT/R's on Moabs | Hansen Offroad Steel F/R Bumpers | Warn 9000xi Winch | Edge Performance Chip | Custom CAI | Hella Off-road Lights | Cobra 29 CB | Flash Lights | Recovery Gear | Fire Extinguisher ~

~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~



-Michael-
snobrdrkid07 is offline  
post #6644 of 6789 Old 10-15-2014, 08:47 PM Thread Starter
snobrdrkid07
Web Wheeler
 
snobrdrkid07's Avatar
2004 WJ 
 
Join Date: Jul 2010
Location: Chesapeake/Blacksburg
Posts: 8,851
Garage
I put in the Rear LCA's and the Rear Rotors. Doesn't squeal anymore and the highway torque steer is most definitely reduced. Good day in the garage. Also put Loctite, blue serviceable, on the rear control arm bolts and torqued the crap out of them. 135+ Ft-lbs

I ordered a Mopar Trans Filter however it did not come in any Mopar packaging for says anything that would distinguish it as a Mopar Filter. I am not sure what to do with it, going to contact the seller.

~ 04 WJ Overland 4.7 HO | Graphite Metallic | Quadra-Drive | Vari-Locks | Bilstein 4600ís | ADDCO Sway Bar | Powerstick Exhaust | RB1 | SuperChips Tuned | Much More to Come ~

~ 04 WJ Laredo 4.0 | Selec-Trac | MBP | OME HD 3" Lift | JKS TB | IRO Front LCA's and UCA's| Bilstein 5100's | Silent Armor 245/70/17's | Custom Front D.S. | Stillen Rotors/Pads | Tow Package w/ 3.73's | Moog HD Steering | Kenwood eXcelon HU | Alpine Speakers, Amps, and Subs | Bilstein SS | Auxiliary Transmission Cooler | Rock Lights | Light Bars | Lots of Cool Stuff ~

~ 05 Rubicon Unlimited 4.0 | 6-Speed | Dana 44's | Air Lockers | 4.11 Gears | Rock-Trac 241OR T-Case with 4:1 4-Low | OME HD Springs | Bilstein 5100ís | 245/75/16 Kevlar MT/R's on Moabs | Hansen Offroad Steel F/R Bumpers | Warn 9000xi Winch | Edge Performance Chip | Custom CAI | Hella Off-road Lights | Cobra 29 CB | Flash Lights | Recovery Gear | Fire Extinguisher ~

~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~



-Michael-
snobrdrkid07 is offline  
post #6645 of 6789 Old 10-28-2014, 06:20 PM Thread Starter
snobrdrkid07
Web Wheeler
 
snobrdrkid07's Avatar
2004 WJ 
 
Join Date: Jul 2010
Location: Chesapeake/Blacksburg
Posts: 8,851
Garage
Not much happening. Tightened the front UCA Jam nuts, one of them was hand tight. Likely a source of clunking. Have Ball Joints and Wheel Bearings waiting to go in.









~ 04 WJ Overland 4.7 HO | Graphite Metallic | Quadra-Drive | Vari-Locks | Bilstein 4600ís | ADDCO Sway Bar | Powerstick Exhaust | RB1 | SuperChips Tuned | Much More to Come ~

~ 04 WJ Laredo 4.0 | Selec-Trac | MBP | OME HD 3" Lift | JKS TB | IRO Front LCA's and UCA's| Bilstein 5100's | Silent Armor 245/70/17's | Custom Front D.S. | Stillen Rotors/Pads | Tow Package w/ 3.73's | Moog HD Steering | Kenwood eXcelon HU | Alpine Speakers, Amps, and Subs | Bilstein SS | Auxiliary Transmission Cooler | Rock Lights | Light Bars | Lots of Cool Stuff ~

~ 05 Rubicon Unlimited 4.0 | 6-Speed | Dana 44's | Air Lockers | 4.11 Gears | Rock-Trac 241OR T-Case with 4:1 4-Low | OME HD Springs | Bilstein 5100ís | 245/75/16 Kevlar MT/R's on Moabs | Hansen Offroad Steel F/R Bumpers | Warn 9000xi Winch | Edge Performance Chip | Custom CAI | Hella Off-road Lights | Cobra 29 CB | Flash Lights | Recovery Gear | Fire Extinguisher ~

~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~



-Michael-
snobrdrkid07 is offline  
Reply

Tags
ome hd , OME lift kit , snobrdrkid , wj

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
WJ Build Thread tsconver Grand Cherokee General Discussion 254 12-07-2019 08:28 PM
ZJ dd build as i go thread BlackDaddyZJ Grand Cherokee General Discussion 151 11-05-2012 04:58 PM
I guess its time for my build thread, "Build thread." Escout03 Grand Cherokee General Discussion 81 11-13-2011 01:45 PM
My Build Thread zjrick812 ZJ Grand Cherokee Forum 5 11-16-2010 09:10 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome