Water Pump Woes - JeepForum.com
 
LinkBack Thread Tools
post #1 of 1 Old 08-11-2019, 01:02 PM Thread Starter
JeffMohr
Registered User
 
JeffMohr's Avatar
2002 TJ Wrangler 
 
Join Date: Jan 2012
Location: Menasha
Posts: 19
Water Pump Woes

Had a sleepless night last night, My Jeep overheated and it threw a Cyl 5 misfire code. I replaced the thermostat hoping that was the problem. When that didn't work the "maybe it's a blown head gasket" thought crept into my head. It would only overheat when the rpm's were high. Turns out it was the water pump...Thank god.... If you have a water pump with Plastic vanes (see attached pic) get ready to change it. My old pump vanes were almost freewheeling. It would pump just enough at idle to keep the temp down.

I'm going to go take a nap

Attached Thumbnails
Pump.jpg  

It doesn't ride like a car....It doesn't ride like a truck.... It rides like a JEEP!!
JeffMohr is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome