Rusty coolant - JeepForum.com
 
LinkBack Thread Tools
post #1 of 1 Old 07-30-2019, 06:29 PM Thread Starter
J3rmit
Registered User
 
Join Date: Jul 2019
Posts: 2
Rusty coolant

I just replaced my radiator with a brand new one. When I drained the original fluid it was clear pink (HOAT). I replaced with the same OEM mopar pink antifreeze pink 50/50, burped the system & now its rusty colored. Could have there been air in the line prior to my replacing where exposed parts may have rusted? I'm baffled as to what's happening.

J3rmit is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome