P0871 Code need help - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 06-30-2020, 09:56 AM Thread Starter
RockRoller
Registered User
2009 JK Wrangler 
 
Join Date: Jun 2020
Posts: 2
P0871 Code need help

Hello all,

I'm new to the forum and need assistance with this code issue. I have a 2009 JKU that is throwing this code, but it only throws the code when I stop suddenly or take a sudden right turn from speeds higher than 30mph. Or at least that's what I have observed. If I clear the code and drive around town (~30MPH) then the code doesn't pop up. If I'm coming off the highway and stop at the light, the code pops up. I can almost predict it when driving home from work everyday. I have no other codes and the jeep is otherwise running fine. No limp mode or hard shifting. The jeep does have an auto trans. Any help would be appreciated.

RockRoller is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 06-30-2020, 10:10 AM
Kruzin
Web Wheeler
 
Kruzin's Avatar
2009 JK Wrangler 
 
Join Date: Aug 2007
Location: Lakewood
Posts: 6,403
P0871-OD PRESSURE SWITCH RATIONALITY

Theory of Operation

The Transmission system uses three pressure switches to monitor the fluid pressure in the L/R, 2/4, and OD elements. The pressure switches are continuously monitored for the correct states in each gear. Normal operation will be experienced if no other codes are present. Transmission Control System will ignore the code. Limp-in condition will only occur if DTC P0871 is present with a DTC P0706.


When Monitored: Whenever the engine is running.
Set Condition: The DTC is set if one of the pressure switches is open or closed at the wrong time in a given gear. If the problem is identified for 3 successive key starts, the transmission will go into limp-in mode and the MIL will turn on after 10 seconds of vehicle operation.


Possible Causes
RELATED TIPM DTCS PRESENT
LOSS OF PRIME DTC PRESENT
OD PRESSURE SIGNAL CIRCUIT OPEN
OD PRESSURE SIGNAL CIRCUIT SHORT TO GROUND
OD PRESSURE SIGNAL CIRCUIT SHORT TO VOLTAGE
TRANSMISSION SOLENOID/PRESSURE SWITCH ASSEMBLY
POWERTRAIN CONTROL MODULE

'09 JK Rubicon
'01 XJ Sport
'10 Fusion
Kruzin is offline  
post #3 of 3 Old 06-30-2020, 11:48 AM Thread Starter
RockRoller
Registered User
2009 JK Wrangler 
 
Join Date: Jun 2020
Posts: 2
Thx, I guess I’m looking to see if anyone has gone through this and they determined the likely cause. From other posts on this topic they experienced limp mode and/or the hard shifting where I am not. Probably just a sensor? Or should I go through a predetermined ritual.
RockRoller is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome