HELP! 95 ZJ 4.0 will not heat up after 2 new TSATS - JeepForum.com
 1Likes
  • 1 Post By wildbill23c
 
LinkBack Thread Tools
post #1 of 3 Old 12-28-2017, 10:09 PM Thread Starter
paulnovinsky
Registered User
 
Join Date: Dec 2017
Posts: 2
HELP! 95 ZJ 4.0 will not heat up after 2 new TSATS

95 ZJ 4.0 bone stock just purchased for a winter beater, it would not get up to running temp on the gauge cluster, changed tstat out for a 190 stant, did not fix the issue, then did a 195 napa, still no resolution. i have flushed the heater core. made sure i burped the coolant system after any time i screwed with it, new radiator cap and a new coolant temp sensor on the thermostat housing. I have no idea what else there is left to do. could my mechanical fan be staying engaged for some reason just enough to keep pushing air over the motor never allowing my temp to go above 165? i can not get the damn thing to touch 190. please help anyone and everyone thanks guys. also i must add that my cabin heat is beyond fine, i have great heat inside the cab , so i really am confused

paulnovinsky is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 12-28-2017, 10:22 PM
wildbill23c
Registered User
1998 ZJ 
 
Join Date: Dec 2017
Posts: 558
If you are getting heat in the cab, then the problem lies in the temperature sensors. I've had issues like this in the past in different vehicles and the final fix was a true coolant temperature gauge replacing the electronic sensors which are what the gauges on the dash really are, they are just glorified idiot lights so they aren't going to give you a true reading.
paulnovinsky likes this.
wildbill23c is offline  
post #3 of 3 Old 12-31-2017, 06:29 AM Thread Starter
paulnovinsky
Registered User
 
Join Date: Dec 2017
Posts: 2
Thank you so much for the input, sorry for the delayed response. SO i checked the sensors, they all work, i replaced the coolant temp sensor, the engine temp sending sensor on the back of motor also works fine. at this point i am at a loss. i can touch my radiator cap after driving for hours. I blocked the grill with cardboard, nothing changes. Is there anything left to change aside from a radiator and water pump? this is wild to me
paulnovinsky is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome