Error P0452, EVAP Pressure Switch A Stuck Closed - JeepForum.com
 
LinkBack Thread Tools
post #1 of 4 Old 09-27-2021, 01:15 PM Thread Starter
TonyMart
Registered User
 
Join Date: Sep 2021
Posts: 2
Error P0452, EVAP Pressure Switch A Stuck Closed

When I measure voltage to the EVAP purge solenoid, either ignition on or engine running, it reads 0 volts.

By EVAP purge solenoid, I mean the valve in the engine compartment. Hope I have the name right.

I have had other error, but after resetting I get P0452.

If I connect the valve directly to the battery, it clicks and lets air through, other wise its closed.

No idea what is wrong.

Tank you,
Tony

TonyMart is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 09-27-2021, 01:46 PM
jtec
Registered User
 
jtec's Avatar
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 10,556
what color is your car?

Might also tell us year, model, engine, and ALL codes. .

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
post #3 of 4 Old 09-27-2021, 11:06 PM Thread Starter
TonyMart
Registered User
 
Join Date: Sep 2021
Posts: 2
Quote:
Originally Posted by TonyMart View Post
When I measure voltage to the EVAP purge solenoid, either ignition on or engine running, it reads 0 volts.

By EVAP purge solenoid, I mean the valve in the engine compartment. Hope I have the name right.

I have had other error, but after resetting I get P0452.

If I connect the valve directly to the battery, it clicks and lets air through, other wise its closed.

No idea what is wrong.

Tank you,
Tony
Update:

I checked for leaks using a smoke tool and didn't find any. The Purge Solenoid seams to be working. It opens and closes when I apply 12v to it.
The Fuel Vapor Leak Detection Pump, I replaced with a new one and didn't fix the problem.
TonyMart is offline  
 
post #4 of 4 Old 09-28-2021, 08:47 AM
jtec
Registered User
 
jtec's Avatar
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 10,556
X2 year model engine

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome