89 YJ w/ 4.0 not firing - JeepForum.com
 
LinkBack Thread Tools
post #1 of 6 Old 02-23-2020, 04:19 PM Thread Starter
DrOdie
Registered User
1989 YJ Wrangler 
 
Join Date: Sep 2016
Posts: 4
89 YJ w/ 4.0 not firing

I'm going to get to work Saturday on the YJ and just wanted to gather some ideas so I can tear into it productively. Here's the current status:

I'm getting no spark. I've put in all new plugs and wires, distributor cap, and ignition coil. Voltages to the coil check out good, so it appears everything works up until it gets through the distributor.

Is there anything I'm missing that may cause this other than a distributor issue?

DrOdie is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 02-26-2020, 11:59 AM
CodemanLivs
Registered User
 
CodemanLivs's Avatar
1995 XJ Cherokee 
 
Join Date: Jun 2019
Posts: 33
I'm not sure if your model has it, but if it has a Crank Position Sensor(CPS) on the driver's side of the bell housing(up in the hardest spot to get to) against the firewall.
Then I would start with that.
CodemanLivs is offline  
post #3 of 6 Old 02-27-2020, 03:06 AM
Kcooks12
Registered User
 
Kcooks12's Avatar
2001 TJ Wrangler 
 
Join Date: Jun 2018
Posts: 22
Second the crank position sensor. Very common issue
Kcooks12 is offline  
 
post #4 of 6 Old 03-05-2020, 09:30 AM Thread Starter
DrOdie
Registered User
1989 YJ Wrangler 
 
Join Date: Sep 2016
Posts: 4
89 YJ w/ 4.2 not firing

So I misstated in my original post that this was a 4.0, when I meant 4.2. Long story short I have been in my Haynes manual and YouTube and it appears there is no CPS on this model.

The only other things I can think of is the distributor itself, the ICM, or a ground.
DrOdie is offline  
post #5 of 6 Old 03-06-2020, 11:48 AM
Kcooks12
Registered User
 
Kcooks12's Avatar
2001 TJ Wrangler 
 
Join Date: Jun 2018
Posts: 22
I would agree, if it were me I'd check grounds, then replace ignition coil as well as distributor cap and rotor. If still no spark then pickup coil in the distributor and icm. Should be less than $100.
Kcooks12 is offline  
post #6 of 6 Old 03-08-2020, 02:34 PM Thread Starter
DrOdie
Registered User
1989 YJ Wrangler 
 
Join Date: Sep 2016
Posts: 4
89 YJ w/ 4.2 not firing

Alright, cool. I'll give it a shot and post back soon. Thanks for letting me pick your brain!
DrOdie is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome