2012 Liberty loud tapping or knocking under load - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 06-14-2019, 10:00 PM Thread Starter
ShouldOfGotaXJ
Registered User
 
Join Date: Jun 2019
Posts: 4
Kind of have a feeling where this going already but just in case I maybe missing something. I've got a 2012 Jeep liberty sport 4x4 about 83000 miles on it and I'm experiencing a loud tapping or knocking from the lower end towards the back of the motor along with a rattle on cold starts that only last a second. So far I've changed oil, oil filter, spark plugs ignition coil boots, wires, along with changing out pcv valve. I've also dropped transmission pan and changed fluid and filter. Both the trans fluid and oil looked good not sludge or burnt. I notice the knocking sound at low rpms as I'm taking off at a light or if I hold brake and give light on the gas. The tapping goes from 500-1000rpm then clears up after that. No engine lights, no transmission slipping or getting hot. Have an odb2 scanner coming in tomorrow although I'm not sure how much that will help unless I can pull up some old codes. I have noticed on a couple ocassions that the rpms will bounce alittle bit at a stop sign but other than that it idols absolutely fine no rough ideal no surging that's noticable anyway. Just curious if anyone has experienced anything else like this. Right now I'm leaning towards a motor on its way out or possibly a torque converter. Also on these transmissions is it normal to see the tac wanting to stay in the Eco zone even at highway speeds of 65-70. Mine seems to want to stay below 2500 until I get closer to 80mph. Thanks any input would be great

ShouldOfGotaXJ is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 06-20-2019, 08:03 PM Thread Starter
ShouldOfGotaXJ
Registered User
 
Join Date: Jun 2019
Posts: 4
Think I may have narrowed it down to an exhaust manifold gasket leak. Will take heat shield off this weekend and explore further. Money is on a broken manifold bolt since Chrysler seems to be known for that and my luck tends to go that way. Looked around a little deeper the other night and the combination of the rattle on cold start, listening to the sound a little more resembles a flapping (as my lady would say) instead of a knocking and having a rich fuel trim that's all over the place but not enough to throw a code on bank two makes me feel a little better... maybe.
ShouldOfGotaXJ is offline  
post #3 of 3 Old 06-20-2019, 08:25 PM Thread Starter
ShouldOfGotaXJ
Registered User
 
Join Date: Jun 2019
Posts: 4
Couple other things I've noticed that have me pointing to this is it's more noticeable some times than others, the engine compartment seems to have a faint exhaust smell and haze at times and my IAT temps seem to be getting up there in stop and go traffic which makes me think the exhaust gases aren't getting pushed all the way out. So we'll see how it goes tomorrow.
ShouldOfGotaXJ is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome