2006 Jeep LJ Idle and Shifting issues - JeepForum.com
 
LinkBack Thread Tools
post #1 of 5 Old 06-23-2021, 04:22 PM Thread Starter
sgtgrattan
Registered User
 
sgtgrattan's Avatar
2008 MK Patriot 
 
Join Date: Jun 2018
Location: Wallingford
Posts: 10
2006 Jeep LJ Idle and Shifting issues

Hello,

Just recently bought a Jeep Wrangler Unlimited 2006. I have changed the spark plugs, replace the coil pack, cleaned the throttle body, new TPS, new MAP, new IOC, put midgrade and Seafoam in the tank. I still have a rough idle, its bounces around 500rpm's, drives good just bad idle. Transmission shifts hard going from first to second, until its warmed up then its fine. Im not sure where to go from here. Is it my computer, is that messing up my idle also, or an air leak? I have watched many YouTube videos, and now im stuck.

Thank you'

Kelly


"It only works when the wheels are on the ground Sir!"
sgtgrattan is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 07-02-2021, 07:53 PM
ToucanTJ
Registered User
 
Join Date: Jul 2021
Posts: 4
Quote:
Originally Posted by sgtgrattan View Post
Hello,

Just recently bought a Jeep Wrangler Unlimited 2006. I have changed the spark plugs, replace the coil pack, cleaned the throttle body, new TPS, new MAP, new IOC, put midgrade and Seafoam in the tank. I still have a rough idle, its bounces around 500rpm's, drives good just bad idle. Transmission shifts hard going from first to second, until its warmed up then its fine. Im not sure where to go from here. Is it my computer, is that messing up my idle also, or an air leak? I have watched many YouTube videos, and now im stuck.

Thank you'

Kelly
Okay so not saying this will fix your issue but i had the same idle problem and it turned out to be a bad upstream O2 sensor. i had gone through like 4 IAC Valves and was completely confused on why the idle kept dropping below 500.
ToucanTJ is offline  
post #3 of 5 Old 07-02-2021, 08:15 PM
jtec
Registered User
 
jtec's Avatar
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 10,152
ok this jeep is new to you - SO i would ask

Does the CEL come on at every start for @2 seconds then go out?

I am not recognizing "IOC" help me out...

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
 
post #4 of 5 Old 07-03-2021, 04:29 AM Thread Starter
sgtgrattan
Registered User
 
sgtgrattan's Avatar
2008 MK Patriot 
 
Join Date: Jun 2018
Location: Wallingford
Posts: 10
Thank you, I might as well give that a shot, everything else is new lol.

"It only works when the wheels are on the ground Sir!"
sgtgrattan is offline  
post #5 of 5 Old 07-03-2021, 04:30 AM Thread Starter
sgtgrattan
Registered User
 
sgtgrattan's Avatar
2008 MK Patriot 
 
Join Date: Jun 2018
Location: Wallingford
Posts: 10
Yes the engine light comes on then goes out, no codes are stored, and sorry the Idle Control Valve. Thank you.

"It only works when the wheels are on the ground Sir!"
sgtgrattan is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome