2003 grand Cherokee running hot. - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 08-09-2019, 05:19 AM Thread Starter
tallross
Registered User
 
Join Date: Aug 2019
Posts: 1
2003 grand Cherokee running hot.

running hot after five minutes on the road. ? changed the thermostat . no help. Is it possible to have a bad water
pump even if there is no leaking from the pump. The electric fan is constantly running.

tallross is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 08-09-2019, 06:09 AM
grayWJ4x4
Senior Member
 
Join Date: Feb 2016
Location: Los Angeles
Posts: 735
Itís rare but it not unheard of. You could also have a bad radiator. Could be clogged or a pin hole somewhere or have a bad radiator cap.
Buy a new cap itís just five bucks and do a pressure test.
Check the oil make sure there is no water in it too.
grayWJ4x4 is offline  
post #3 of 3 Old 08-09-2019, 06:24 AM
jtec
Registered User
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 6,054
this is a 2003 WJ with a 4.0L ?

The engine cooling fan is always on, AC Defrost are OFF?
What is the indication of running hot - just temp gauge, boiling over?

Yes a water pump can fail without weeping.

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome