93 jeep grand cherokee wont start after fuel filter replacemnt - JeepForum.com
 
LinkBack Thread Tools
post #1 of 2 Old 06-16-2019, 06:57 PM Thread Starter
Krazysurfer
Registered User
 
Join Date: Jun 2019
Posts: 1
93 jeep grand cherokee wont start after fuel filter replacemnt

I replace the idle air control valve spark plugs and fuel filter now i can not get the jeep to start and idle. At first it tried now it doesnt even sound like its getting gas. I primed it multiple times. Bleed through the fuel rail. Plent of gas spraying anyone know whats going on please help?

Krazysurfer is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 06-24-2019, 10:24 PM
jeep_2017
Registered User
 
Join Date: Aug 2017
Posts: 10
i wonder if removing the battery for a day would help the computer relearn the new idle control valve.

did you check all the new parts against the old ones, to ensure they are exactly the same.

i would be tempted to put the old parts back in and see if that helps, i assume it ran better before the new parts.
jeep_2017 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome