Tipm - JeepForum.com
 
LinkBack Thread Tools
post #1 of 6 Old 10-20-2021, 04:38 PM Thread Starter
Gmck1801
Registered User
 
Join Date: Oct 2021
Posts: 1
Tipm

Recently I purchased a 08 wrangler unlimited and when I crank it up the wipers come on and the lights wont turn on also the turn signals wont work either. Could this be the TIPM? If so will a tipm from any Jeep, dodge or Chrysler wont in mine?

Gmck1801 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 10-21-2021, 12:01 PM
cranbiz
Moderator
 
cranbiz's Avatar
2012 JK Wrangler 
 
Join Date: Nov 2015
Location: Wentworth
Posts: 5,336
Disconnect the negative battery terminal for about 5 minutes and then reconnect it. Make sure that the 10 mm nuts that release the clamps do not have any wire terminals connected to them.

The symptoms you describe could be a voltage issue (loose connection, battery going bad, etc) or the TIPM. The disconnect should reset the TIPM and if it's simply a computer glitch, it will go away. You need a Wrangler specific TIPM, not anyone will do. It also has to be the right generation. A TIPM from a 12 may not work in a 08. If you go the TIPM route, buy one based on the part number of yours.

02 WJ Laredo, heavily optioned but stock
12 JK, 3.5" Teraflex/Franken lift, Bilstein 5100's, BFG KM3's 37x12.5/R17
17 WK2 Trailhawk
KN4BBA
cranbiz is offline  
post #3 of 6 Old 11-24-2021, 06:32 AM
JKLINGO
Registered User
2008 JK Wrangler 
 
Join Date: Sep 2017
Posts: 2
TiPM / Clock Sping Multifuntion

OK lost my headlights, Wipers and Signals and dome light. Pulled TIPM sent to TIPM rebuilders , The found nothing wrong with TIPM, Replaced Multifunction switch, still no success, replaced wiper switch, still nothing,
replaced clock spring. still nothing. Disconnected battery numerous times. Re-seated TIPM connections numerous times. ocationally things will work for short period of time.


When I disconnect the multifunction switch headlights an wiper are on constantly.


Any help as what to try next on my 2008 JKU rubicon
JKLINGO is offline  
 
post #4 of 6 Old 11-24-2021, 07:16 AM
222Doc
Registered User
 
222Doc's Avatar
2012 JK Wrangler 
 
Join Date: Sep 2011
Location: Lake Havasu City
Posts: 10,414
Garage
no codes. I would be looking at grounds. meaning Not to just look but take off and clean it while looking.

Home of the Parker Desert Splash

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
222Doc is offline  
post #5 of 6 Old 11-24-2021, 10:21 AM
JKLINGO
Registered User
2008 JK Wrangler 
 
Join Date: Sep 2017
Posts: 2
Went over all grounds and cleaned. Forgot to mention. Battery at 12.5 v and passes load test. No recent modifications. I do get

Codes
U0118B & U0118A Lost Communication with AFS Module left and Right
B1630 & B1620 Right and left low beam control circuit high (These I believe gave been on for two years after installingOracle LED Headlights
U0186 and U0184 Lost Communication with Radio and Factory amp. These have been on for years after aftermaket stereo intsall.


Today I turned key on the gather codes. Lights and wipers com on intermittently
.
JKLINGO is offline  
post #6 of 6 Old 11-30-2021, 01:48 PM
JoonHoss
Registered User
 
JoonHoss's Avatar
2011 JK Wrangler 
 
Join Date: Mar 2005
Location: Washington State
Posts: 10,031
Makes me wonder if your stereo is wired correctly, and or backfeeding through a ground, especially if it doesn't think its connected

Hoss

I used to be a people person, until people ruined it...
JoonHoss is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome