ZJ dies randomly and refuses to restart unless I spray intake w/ether - JeepForum.com
Reply
 
LinkBack Thread Tools
post #1 of 23 Old 05-27-2020, 02:44 AM Thread Starter
Bdrew
Registered User
 
Bdrew's Avatar
 
Join Date: May 2020
Posts: 11
ZJ dies randomly and refuses to restart unless I spray intake w/ether

So I'll randomly be driving and all the sudden Jeep just dies then will refuse to re start unless I spray intake with starting fluid... I have. 1995 grand Cherokee zj 4.0 v6... Any ideas as to what might be the cause of this???

Any help/suggestions would be greatly appreciated


-B

Bdrew is offline  
Sponsored Links
Advertisement
 
post #2 of 23 Old 05-27-2020, 04:40 AM
V8GCZJ
Registered User
 
Join Date: Sep 2018
Posts: 549
V8GCZJ is offline  
post #3 of 23 Old 05-27-2020, 05:02 AM
jtec
Web Wheeler
 
jtec's Avatar
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 8,228
this is likely an I6 not a V engine.

My first thought as it will fire up with spray is to check fuel pressure.
Next might want to look at plugs.

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
 
post #4 of 23 Old 05-27-2020, 05:12 AM
MikeMiller98GC
Registered User
 
Join Date: May 2020
Posts: 2
My 98 Grand Cherokee use to do the same thing and I found the problem was in the ECM. Company in Florida wanted $600 to repair it but since I have a degree in electronics and all the tools needed. WHY NOT! The Jeep hasn't stalled in over a year. The hardest part of the job is getting the board out of the potting material. I would recommend looking at ever solder joint through a microscope (if possible). Some of the joints I though looked good didn't look so good under a microscope. I used a de-soldering iron to remove all the old solder to lay down fresh solder. Hope this helps, I fought this problem for a year before the fix! Youtube 98 Grand Cherokee ECM repairs
MikeMiller98GC is offline  
post #5 of 23 Old 05-27-2020, 05:45 AM
jtec
Web Wheeler
 
jtec's Avatar
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 8,228
Right now I think PCM is a leap in troubleshooting. I cant see the cause and effect of spraying starting fluid on solder loints.

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
post #6 of 23 Old 05-27-2020, 02:44 PM
MikeMiller98GC
Registered User
 
Join Date: May 2020
Posts: 2
The fuel pump is control through the computer and with the bad solder joints the fuel pump would just quit pumping. I had to jump start mine after every stall, that is when a guy mentioned the zip tie solution for the computer. Zip ties worked but after researching the problem further I decided to do the permanent fix.
MikeMiller98GC is offline  
post #7 of 23 Old 05-29-2020, 11:00 AM Thread Starter
Bdrew
Registered User
 
Bdrew's Avatar
 
Join Date: May 2020
Posts: 11
ZJ dies randomly and refuses to restart unless I spray intake w/ethe

Why would I spray starting fluid on the solder ??? I'm spraying it in the intake
Bdrew is offline  
post #8 of 23 Old 05-29-2020, 11:01 AM Thread Starter
Bdrew
Registered User
 
Bdrew's Avatar
 
Join Date: May 2020
Posts: 11
So now it's just completely dead and refuses to start at all... Took off a spark plug and apparently it's not getting any spark
Bdrew is offline  
post #9 of 23 Old 05-29-2020, 11:02 AM Thread Starter
Bdrew
Registered User
 
Bdrew's Avatar
 
Join Date: May 2020
Posts: 11
It's now STUCK up at Starbucks so I could really use some help... What's the most likely cause of no spark??
Bdrew is offline  
post #10 of 23 Old 05-29-2020, 11:33 AM
jtec
Web Wheeler
 
jtec's Avatar
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 8,228
sorry my bad grammar - why would spraying starting fluid into intake have any affect on solder in PCM?

You need to check

fuel pressure. with a gauge.
Is there 12v at injectors?
is there 12v at coil?

MikeMiller98GC correct the issue is known BUT I thought to work thru the BASICS before delving into PCM.

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
post #11 of 23 Old 05-29-2020, 12:49 PM
jeepjeepster
Registered User
 
Join Date: Dec 2004
Posts: 3,660
Does the check engine light come on when you first turn the ignition on?

1994 ZJ-I6 w/270,000 mi
1998 ZJ 5.9 w/66,000 mi Slate Black
2004 KJ w/108,000 mi
jeepjeepster is offline  
post #12 of 23 Old 05-29-2020, 02:38 PM
At1bob
Registered User
 
At1bob's Avatar
1997 ZJ 
 
Join Date: Jul 2015
Location: Mechanicsville
Posts: 19
Lazy PCM

Quote:
Originally Posted by MikeMiller98GC View Post
My 98 Grand Cherokee use to do the same thing and I found the problem was in the ECM. Company in Florida wanted $600 to repair it but since I have a degree in electronics and all the tools needed. WHY NOT! The Jeep hasn't stalled in over a year. The hardest part of the job is getting the board out of the potting material. I would recommend looking at ever solder joint through a microscope (if possible). Some of the joints I though looked good didn't look so good under a microscope. I used a de-soldering iron to remove all the old solder to lay down fresh solder. Hope this helps, I fought this problem for a year before the fix! Youtube 98 Grand Cherokee ECM repairs
I also believe this is a leap in troubleshooting. But if you go this route search for lazy PCM and there is a good thread on rebuilding it and replacing the bad capacitors.
At1bob is offline  
post #13 of 23 Old 05-29-2020, 02:44 PM
At1bob
Registered User
 
At1bob's Avatar
1997 ZJ 
 
Join Date: Jul 2015
Location: Mechanicsville
Posts: 19
Need the codes

I got stuck once like that and it was the camshaft position sensor located in the distributor. It was easy to change . The crankshaft position sensor is not easy, do not confuse them since they have the same acronym. So you need the codes to determine which it might be. Also I did not try to spray any starter fluid at the time to see if that made a difference.
At1bob is offline  
post #14 of 23 Old 05-29-2020, 08:27 PM Thread Starter
Bdrew
Registered User
 
Bdrew's Avatar
 
Join Date: May 2020
Posts: 11
The only 2 codes I get is 32 and 55
Bdrew is offline  
post #15 of 23 Old 05-29-2020, 08:33 PM
jeepjeepster
Registered User
 
Join Date: Dec 2004
Posts: 3,660
You sure on that 32? The V6 doesnt have an EGR valve... Nor does the I6....

1994 ZJ-I6 w/270,000 mi
1998 ZJ 5.9 w/66,000 mi Slate Black
2004 KJ w/108,000 mi
jeepjeepster is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome