Wont Shift after Highway? - JeepForum.com
 
LinkBack Thread Tools
post #1 of 9 Old 01-21-2015, 03:39 PM Thread Starter
Gibby913
Registered User
1997 ZJ 
 
Join Date: Aug 2008
Location: NH
Posts: 288
Wont Shift after Highway?

My jeep is having a hard time shifting after going over 65 on the highway. As long as I don't go on the highway she shift fine. But the moment I get on the highway and then get off to slower speeds, she'll downshift but then go to 3000rpm without shifting. What causes this? No metal in the pan, recently upgraded all electronics from cascade, except for the speed sensor on the outside of tranny. Any ideas?

Also, after I replaced all electronics inside case she seemed to shift fine even after coming off of highway....She just started doing it again this past week.


-=Gibby=-
1997 Jeep Grand Cherokee 4.0L I-6 150,600
Gibby913 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 01-21-2015, 03:48 PM
Pierre_r
Registered User
 
Pierre_r's Avatar
1989 XJ Cherokee 
 
Join Date: Jul 2009
Location: Sweden
Posts: 1,144
I hade something like that happen to mine and it was the lock up solenoid that had failed.
It stored a code for that fault so yours should also have a saved code.
I checked the codes on my 93 with the keytrick.
Yours are easier since you have an obd outlet, just hook up a scanner/reader and see what it says.

Jeep Cherokee XJ 4.0 -89
Jeep Cherokee XJ 4.0 -90 (partsjeep)
Jeep Grand Cherokee 5.2 -93
Chevrolet Silverado 2500 6.5TD -94
Chevrolet C20 6.2 -82
Pierre_r is offline  
post #3 of 9 Old 01-21-2015, 05:25 PM
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Posts: 9,049
when you go over 65 then stop, you have first gear only. when you turn the engine off and restart, it shifts fine until you go over 65, then the problem starts over. is this an accurate interpretation?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ZeeJay1997 is offline  
 
post #4 of 9 Old 01-23-2015, 11:57 AM Thread Starter
Gibby913
Registered User
1997 ZJ 
 
Join Date: Aug 2008
Location: NH
Posts: 288
@Zee Jay

Yep pretty much. But I usually dont have to turn the engine off. I just pop her in neutral and that usually does the trick. Usually. But if not then yes shutting her off always fixes the issue.

@Pierre

Wouldn't it throw a light if I had a code to read? I mean I'll go ahead and slap the reader in but I dont have any lights on. Just shifting weird after +65mph.

-=Gibby=-
1997 Jeep Grand Cherokee 4.0L I-6 150,600
Gibby913 is offline  
post #5 of 9 Old 01-23-2015, 01:51 PM
Pierre_r
Registered User
 
Pierre_r's Avatar
1989 XJ Cherokee 
 
Join Date: Jul 2009
Location: Sweden
Posts: 1,144
Newer might do it, but my 93 did not.

Jeep Cherokee XJ 4.0 -89
Jeep Cherokee XJ 4.0 -90 (partsjeep)
Jeep Grand Cherokee 5.2 -93
Chevrolet Silverado 2500 6.5TD -94
Chevrolet C20 6.2 -82
Pierre_r is offline  
post #6 of 9 Old 01-28-2015, 07:35 AM Thread Starter
Gibby913
Registered User
1997 ZJ 
 
Join Date: Aug 2008
Location: NH
Posts: 288
Quote:
Originally Posted by ZeeJay1997 View Post
when you go over 65 then stop, you have first gear only. when you turn the engine off and restart, it shifts fine until you go over 65, then the problem starts over. is this an accurate interpretation?
Sooooo. Did you have any guidance to give? It seemed like you had a thought.....did it drift away? lol. Still an issue, please help!

-=Gibby=-
1997 Jeep Grand Cherokee 4.0L I-6 150,600
Gibby913 is offline  
post #7 of 9 Old 01-28-2015, 05:24 PM
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Posts: 9,049
i was also thinking tcc solenoid but i had another question and got too busy to type it out... so yes i did drift off...

if you dont do anything but stop, does the engine choke down go dead? and if you put it neutral does it stop it from choking?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ZeeJay1997 is offline  
post #8 of 9 Old 01-28-2015, 11:05 PM
dan66cj5
Registered User
1966 CJ5 
 
Join Date: Mar 2004
Posts: 153
Might be time for a rebuild.. my trans had all kinds of weird problems till it finally quit. Seals may be blown, bands worn out, clutches burnt.. Have you adjusted the bands ? My trans only had 135k when it went.
dan66cj5 is offline  
post #9 of 9 Old 02-03-2015, 11:01 AM Thread Starter
Gibby913
Registered User
1997 ZJ 
 
Join Date: Aug 2008
Location: NH
Posts: 288
@Zeejay No, engine doesnt choke at all. Just the tranny sometimes doesnt want to hop out of first.

@dan - just replaced all solenoids / electronics and theres no sign of damage inside case. No substantials shavings or chunks etc etc

-=Gibby=-
1997 Jeep Grand Cherokee 4.0L I-6 150,600
Gibby913 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome