white smoke from engine after swapping out radiator, waterpump and thermo - JeepForum.com
 
LinkBack Thread Tools
post #1 of 9 Old 01-07-2012, 12:46 PM Thread Starter
specspecimen
Registered User
1997 XJ Cherokee 
 
Join Date: Jan 2012
Location: salt lake city
Posts: 3
white smoke from engine after swapping out radiator, waterpump and thermo

I am new here and all these forums have been super helpful in the past so hopefully I can find a solution to this problem quick because I start class Monday and am a poor college student. Typical story but whatever.

Anyway I replaced my radiator, water pump and thermostat yesterday on my 1997 Jeep Grand Cherokee 4.0 to stop a leak that was happening. Filled my radiator back up and now whenever the car runs white smoke comes from the engine. I do not understand why but if there is any solution anyone knows could they please let me know what it is and how I might go about fixing it!

You all are awesome

specspecimen is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 01-07-2012, 12:48 PM
PolkaPower
Registered User
 
PolkaPower's Avatar
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss
Posts: 22,719
Did you spill fluids on the exhaust and it's burning it off?
PolkaPower is offline  
post #3 of 9 Old 01-07-2012, 12:49 PM Thread Starter
specspecimen
Registered User
1997 XJ Cherokee 
 
Join Date: Jan 2012
Location: salt lake city
Posts: 3
the smoke is not coming out of the tailpipe, rather it is coming off the engine itself.
specspecimen is offline  
 
post #4 of 9 Old 01-07-2012, 12:52 PM
PolkaPower
Registered User
 
PolkaPower's Avatar
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss
Posts: 22,719
Like I said you could have spilled some fluid on the headers or block and it's heating up and burning off. When I fixed my trans some fluid dripped down on the header pipes and burned off white. I was alarmed at first until I went under the jeep while it was running and saw where the smoke was coming from.
PolkaPower is offline  
post #5 of 9 Old 01-07-2012, 12:53 PM
RED-85-Z51
Registered User
1993 ZJ 
 
Join Date: Jul 2010
Location: Pensacola, Fl
Posts: 508
Coolant takes a while to evaporate off, as it doesnt just flash to steam @ 212* like water...if you got coolant on the engine, its going to take a bit to go away.
RED-85-Z51 is offline  
post #6 of 9 Old 01-07-2012, 12:53 PM
caligiuri87
Registered User
1994 ZJ 
 
Join Date: Aug 2011
Location: oskaloosa
Posts: 535
thats what he means lol if u spill it take sa bit for it to burn of. when u start the engine let the rad cap of and see if air comes out if not jsut close it and keep an eye on the temp gauge also grab a flashlight and look around maybe its leaking outta hose u didnt clamp good. i think its just burning off can take a bit. i had that too. keep an eye on the temp and keep an eye o nthe coolant in the first few days

Shaky.......shaky shaky shakyyyyyyy.....crack boom pow @%^@%@%@[email protected]#$^%&*(^&&%[email protected]!!!!!!
Happy to be a JEEP owner
caligiuri87 is offline  
post #7 of 9 Old 01-07-2012, 12:58 PM Thread Starter
specspecimen
Registered User
1997 XJ Cherokee 
 
Join Date: Jan 2012
Location: salt lake city
Posts: 3
thank you all so much! i really appreciate it. i'm going to take a look at it and let it run right now and we'll see how that goes
specspecimen is offline  
post #8 of 9 Old 01-07-2012, 01:00 PM
Foundrydude
Registered User
1995 ZJ 
 
Join Date: Jan 2011
Location: Flatsville
Posts: 2,689
Let it warm up and dry out, should be no wet areas after 10 or 15 minutes
Foundrydude is offline  
post #9 of 9 Old 01-07-2012, 01:09 PM
PolkaPower
Registered User
 
PolkaPower's Avatar
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss
Posts: 22,719
Quote:
Originally Posted by Foundrydude View Post
Let it warm up and dry out, should be no wet areas after 10 or 15 minutes
That's what she said!
PolkaPower is offline  
Reply

Tags
radiator , smoke , thermostat , water pump , white

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Replacing thermostat, waterpump, and radiator ZJPunk98 ZJ Grand Cherokee Forum 17 06-06-2010 01:05 PM
Low Oil, white smoke JamesLouis ZJ Grand Cherokee Forum 9 10-15-2009 12:19 PM
4.7 white smoke on startup then goes away UNDERDAWG ZJ Grand Cherokee Forum 9 04-25-2009 08:54 PM
White Smoke BRayf78 ZJ Grand Cherokee Forum 22 04-23-2008 12:14 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome