VIC burned out resistor? - Page 2 - JeepForum.com
 1Likes
Reply
 
LinkBack Thread Tools
post #16 of 22 Old 01-27-2016, 12:31 PM Thread Starter
DrReaper
Registered User
1998 ZJ 
 
Join Date: Apr 2014
Posts: 83
Quote:
Originally Posted by kg6mov View Post
*Digs in parts bin*

In my spare, fully functional, 98 VIC there is no component in that position, just empty pads.
Ok thanks I will re solder the rest and replace.

DrReaper is offline  
Sponsored Links
Advertisement
 
post #17 of 22 Old 01-30-2016, 06:35 PM
jswerve
Registered User
1998 ZJ 
 
Join Date: Aug 2005
Posts: 525
My contacts looked good, even under a magnifying glass. I soldered them anyway. My Jeep has been coolant sensor low free for over 6 months after beeping for almost 10 years.

1998 5.9 |3.5" IRO lift w/adj CA and track bars | Bilstein 5100 | TJ Rubi wheels 245/75/16
jswerve is offline  
post #18 of 22 Old 02-12-2016, 08:06 PM Thread Starter
DrReaper
Registered User
1998 ZJ 
 
Join Date: Apr 2014
Posts: 83
We soldered the board and replaced it. It looks good now. I think the best thing about my jeep is the support I get here! Really enjoying fixing things as they come up.
DrReaper is offline  
 
post #19 of 22 Old 12-22-2018, 08:16 AM
hsk3437
Registered User
 
Join Date: Dec 2018
Posts: 1
vic transistor problem

I need to Vic transistor serial numer datasheet.

Last edited by hsk3437; 12-22-2018 at 09:01 AM.
hsk3437 is offline  
post #20 of 22 Old 12-23-2018, 01:23 PM
muddflow
Registered User
1995 ZJ 
 
Join Date: Dec 2011
Location: _
Posts: 520
Those VIC boards are covered with a conformal coating. The coating should be removed to help see what your looking at and also to perform any re-soldering of parts and traces.

https://en.wikipedia.org/wiki/Conformal_coating

Some people use a plastic tool to scrape it off or you can use a conformal coating remover such as

https://www.zoro.com/techspray-confo...-n/i/G4278102/
muddflow is offline  
post #21 of 22 Old 03-14-2020, 11:45 PM
sushilx
Registered User
 
Join Date: Jan 2018
Posts: 2
ZJ VIC Failure

i recently had similar issue of my 97 ZJ V8, there was a burning smell and the fuse blown out. Both RADIO and AC control stopped working alone with VIC. I found the VIC power transistor failed and
due the PCB track short/arcing at the high voltage area (@ 53V for VFD). After tracing the base/gate circuit, I tried to substitute MOSFET IRFZ46N (since original P/N is not visible and no correct information available on forums) . It works fine so far. Any 60-80v MOSFET with Id 26A or higher may work. There may chances for capacitor failure, mine all of them are fine.
Benthal8 likes this.
sushilx is offline  
post #22 of 22 Old 03-16-2020, 11:22 PM
fawndog
Registered User
 
fawndog's Avatar
1997 ZJ 
 
Join Date: Feb 2020
Posts: 44
If it's any help, I have 2 VICs for cheap, I gave up on trying to make one work. The other is from a 95, condition unknown.
$20 shipped.
fawndog is offline  
Reply

Tags
vic , zj

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome