Vehicle Information Center - JeepForum.com
 
LinkBack Thread Tools
post #1 of 7 Old 06-01-2020, 08:19 AM Thread Starter
bobbrugge
Registered User
 
Join Date: Sep 2017
Posts: 36
Vehicle Information Center

I posted here before, not sure what happened to the post, it seems to have disappeared.
On a 94 ZJ with the 5.2. The screen that flashes and tells me sensors have gone bad when they haven't.
What runs that? I had read a thread about how to fix it that I can't find.
Is that the same thing that runs the compass and fuel mileage information thingie? I don't know what that is called. It sits against the headliner above and behind the rear view mirror.

I have a 96 that has been down graded to a parts car. It too is a ZJ. Can I swap what ever runs that stupid flashy screen from my 96 to my 94?
The 96 doesn't have the stupid flashy screen, but it does have the compass and the fuel mileage thing. And they work.

I would think I would have to swap out the brain, which I would't think would be a huge issue as both vehicles have the same power plant and drive train. But I would expect my odometer to show the 325k miles the 96 has and not the 240k miles the 94 actually has.
Am I right? Misguided? Just plain wrong? Help me out here...
TIA and have a great day!

bobbrugge is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 06-01-2020, 09:04 AM
jtec
Web Wheeler
 
jtec's Avatar
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 8,243
I would suspect the 94 OBD1 and the 96 OBDII would not swap. I always discourage swapatronics. First lets try and address the issue -

Anyway what is wrong with VIC in your 1994 ZJ 5.2L?
What sensors are being reported as BAD?

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
post #3 of 7 Old 06-01-2020, 09:12 AM
MaintMech
Old and in the way
 
MaintMech's Avatar
1996 ZJ 
 
Join Date: Feb 2011
Location: Farmington
Posts: 829
"Coolant Sensor Bad" FINALLY FIXED!!!! - JeepForum.com


This might be what you're looking for.

'96 Grand Laredo, 4.0, Stock, Daily Driver

I fought Oracle and Oracle won!

Originally Posted by coralman
If the faith isn't there,the doubt is.
MaintMech is offline  
 
post #4 of 7 Old 06-01-2020, 12:13 PM Thread Starter
bobbrugge
Registered User
 
Join Date: Sep 2017
Posts: 36
Quote:
Originally Posted by jtec View Post
I would suspect the 94 OBD1 and the 96 OBDII would not swap. I always discourage swapatronics. First lets try and address the issue -

Anyway what is wrong with VIC in your 1994 ZJ 5.2L?
What sensors are being reported as BAD?
Dang, I didn't even think about the OBD! But big as heck, there is no connector!
Ok, so the 94...
It tells me the coolant sensor is bad. No, it isn't...Same with the 4wd switch, you know, the one it doesn't have?
I know the coolant sensor is in fact not bad. The mechanic I bought it from told me he replaced it. I replaced it myself, and either he is right, or there are a bunch of brand new bad sensors out there.

So, swaptronics may not be a great idea. What about swap switches? engines and trans? What other components will and won't swap?

The wipers. The switch has the delay part, yet the wipers only work on low and high with no delay. They also don't park, or return to the down position when shut off. I swapped out the switch, and it isn't that. Then I looked at the fuse and relay box. They are totally different. I am thinking about swapping out the wiper motor assembly and see if that doesn't fix it. As long as the attachment points and the plugs are the same, I am willing to try just about anything.
The 94 has a power steering leak somewhere. I am going to swap the pump and the lines over from the 96. Any short comings there?

What about sound? The 96 is MUCH louder than the 94. The 96 has the stock radio in it and the 94 has an aftermarket head unit. The 94 has the Bose speakers and the 96 has an amp stock from the factory. Thought I would see what parts I can mix and match. You just can't head bang without the loud volume.

What about the rear tailgate shocks, are they interchangeable? They look like they should be, the 94 has shot shocks.
Breaks? I just put new ones on the 96 last winter. Rotors, front and rear. They might be coming with me whether the 94 needs them or not.

There are other things that I am sure I will run across, what ever makes the cruise control work doesn't in the 94, yet does in the 96.

I am bummed too because the 96 has an electrical gremlin that I just can't chase down. Besides that it needs a door. And it still has 325k miles on it. I just put a new fuel pump in it too. If I could figure out what is wrong with it I could fix it, but they would both still need parts. Maybe this way I can turn two mostly crappy jeeps into one almost decent one.
bobbrugge is offline  
post #5 of 7 Old 06-01-2020, 04:41 PM
jtec
Web Wheeler
 
jtec's Avatar
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 8,243
what is the coolant message open, shorted?

Same with 4wd what is message - Failure?
which Tcase?

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
post #6 of 7 Old 06-02-2020, 12:28 PM Thread Starter
bobbrugge
Registered User
 
Join Date: Sep 2017
Posts: 36
Quote:
Originally Posted by jtec View Post
what is the coolant message open, shorted?

Same with 4wd what is message - Failure?
which Tcase?
All of the messages indicate failure, not open or anything else, straight failure.
Not sure what T case it has, It is full time 4wd. So there is no switch.
Will the things I asked about above post pose any issues?

Are there any electrical gremlins that are typical to jeeps?

Old dodges and fords have ground issues typically, VW's typically need the connectors sanded. Anything particular w/ Jeeps?
bobbrugge is offline  
post #7 of 7 Old 06-02-2020, 02:19 PM
jtec
Web Wheeler
 
jtec's Avatar
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 8,243
some info
think CIRCUIT issues
Attached Files
File Type: pdf 94ZJ VIC.pdf (1.00 MB, 4 views)

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome