Surging issue - please help - JeepForum.com
 
LinkBack Thread Tools
post #1 of 5 Old 12-11-2019, 07:48 PM Thread Starter
MackJartel
Registered User
 
Join Date: Feb 2018
Posts: 38
Surging issue - please help

I have a 1995 Grand Zj 5.2 and after warming up the engine surges then stalls.
I’ve replaced
-battery
-fuel and air filter
-computer
-sepentine belt
-tensioner and idler pulley
-coolant temperature sender
-alternator
I’ve had the Jeep hooked up to a fuel pressure gauge and it checked out ok. I also had it hooked up when it was surging and the pressure stayed the same. I’ve cleaned out the throttle body and replaced all the sensors in it last summer. I replaced the cap and rotor last summer too. It starts up very good but has had a low idle and bad mileage ever since I got it 5 years ago. The battery clamps were cleaned but they are kinda beat up. I got code 41 but that went away when I got a new battery...

Any ideas??

MackJartel is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 12-12-2019, 05:36 AM
V8GCZJ
Registered User
 
Join Date: Sep 2018
Posts: 412
Did you replace the IAC and if so with what brand?
V8GCZJ is offline  
post #3 of 5 Old 12-12-2019, 07:39 AM
jtec
Web Wheeler
 
jtec's Avatar
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 6,951
check for vacuum leaks.

Always post fuel PSI if you have it -

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
 
post #4 of 5 Old 12-12-2019, 12:16 PM Thread Starter
MackJartel
Registered User
 
Join Date: Feb 2018
Posts: 38
I replaced the IAC. Not sure what brand but one thing I didn’t mention was that there is an oil leak that’s smoking and I think it’s the valve cover gasket as it’s quite wet with oil. Maybe a vacuum leak?
MackJartel is offline  
post #5 of 5 Old 12-12-2019, 05:02 PM Thread Starter
MackJartel
Registered User
 
Join Date: Feb 2018
Posts: 38
My fuel PSI when running was 40. Approx 37 with engine off.
MackJartel is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome