Still Dying - JeepForum.com
 1Likes
Reply
 
LinkBack Thread Tools
post #1 of 19 Old 05-14-2020, 10:48 AM Thread Starter
MyCarDiesAlot
Registered User
 
MyCarDiesAlot's Avatar
1996 ZJ 
 
Join Date: Feb 2020
Posts: 13
Still Dying

My 1996 ZJ 318 5.2L still has issues with bucking and dropping while driving randomly. Ive read that it can be a myriad of things and was wondering if anyone had advice on what to fix next, as i'm too broke to just keep fixing things till I find it.
Ive replaced:
IACV
TPS
Fuel Pump
Fuel Filter

Jeep is straight piped so check engine is on for O2 because I don't have a downstream. Let me know what you guys think I should fix next. Its like a fun gameshow where I go broke for your entertainment 😂

MyCarDiesAlot is offline  
Sponsored Links
Advertisement
 
post #2 of 19 Old 05-14-2020, 11:21 AM
wingless
Web Wheeler
 
wingless's Avatar
1994 ZJ 
 
Join Date: Sep 2007
Location: Florida
Posts: 3,389
Welcome to the forum.

Has the spark plug wiring TSB been implemented?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wingless is offline  
post #3 of 19 Old 05-14-2020, 12:17 PM Thread Starter
MyCarDiesAlot
Registered User
 
MyCarDiesAlot's Avatar
1996 ZJ 
 
Join Date: Feb 2020
Posts: 13
No, but thank you for showing me. Ill set up my wires like this, as well as cleaning out my throttle body incase theres built up carbon coke.
MyCarDiesAlot is offline  
 
post #4 of 19 Old 05-14-2020, 12:54 PM
wingless
Web Wheeler
 
wingless's Avatar
1994 ZJ 
 
Join Date: Sep 2007
Location: Florida
Posts: 3,389
YW

At some point the vehicle will operate normally, but the User Name will remain, so this song will need to play in the vehicle



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wingless is offline  
post #5 of 19 Old 05-14-2020, 03:02 PM Thread Starter
MyCarDiesAlot
Registered User
 
MyCarDiesAlot's Avatar
1996 ZJ 
 
Join Date: Feb 2020
Posts: 13
I am fully positive it will never operate properly again 😔 What other issues do you think could be causing it? I forgot to mention it happens when i hit bumps too. It feels as though the car gets knocked into a lower gear because it well, gets knocked into a lower gear.
MyCarDiesAlot is offline  
post #6 of 19 Old 05-14-2020, 04:15 PM
StPaul59
Registered User
1998 ZJ 
 
Join Date: Mar 2013
Location: St Paul
Posts: 1,638
GW would recommend cleaning your engine grounds.
StPaul59 is offline  
post #7 of 19 Old 05-15-2020, 04:56 AM
V8GCZJ
Registered User
 
Join Date: Sep 2018
Posts: 549
Quote:
has issues with bucking and dropping while driving randomly.
Have you addressed the plenum issue?


http://www.hughesengines.com/Index/p...p?partid=27091


Any other codes beside the 02's?
V8GCZJ is offline  
post #8 of 19 Old 05-15-2020, 09:00 PM Thread Starter
MyCarDiesAlot
Registered User
 
MyCarDiesAlot's Avatar
1996 ZJ 
 
Join Date: Feb 2020
Posts: 13
Gasket needs a replace. Do you think this is the main issue?
MyCarDiesAlot is offline  
post #9 of 19 Old 06-02-2020, 06:55 PM Thread Starter
MyCarDiesAlot
Registered User
 
MyCarDiesAlot's Avatar
1996 ZJ 
 
Join Date: Feb 2020
Posts: 13
Several weeks later, I haven't gotten around to doing much because i don't have the availability to pull my intake manifold and change the gasket as of right now. I have a feeling my PCM might be bad as all of these electronic issues would link back to my PCM. ill list all of the symptoms again: Car will operate fine cold, but a short bit after reaching running temp, the car will randomly bounce my rpm down as if it is being limited. when i hit bumps my fuel cuts out and sometimes it changes the gear the car is in to a lower one. Even when driving on smooth roads, at running temp my fuel will randomly cut out or fail to ignite, sending it to the exhaust. Once this happens, the car is to the point where it can stall in the road so i try my best to make it to a safe place, park it, and come back in a few hours to retrieve it. If anyone has solved this problem or a similiar one, please let me know. My next idea is to change plugs and plug wires and see if that fixed the misfiring/not firing issue.
MyCarDiesAlot is offline  
post #10 of 19 Old 06-02-2020, 08:04 PM
jeepjeepster
Registered User
 
Join Date: Dec 2004
Posts: 3,660
When it dies, if you turn the ignition off and back on, does the check engine light come on? Have you wiggled the harness on the PCM when this happens? Or even when its running normally.

Its hard to say its the PCM but they can cause this.

How do you know the fuel is cutting out?

1994 ZJ-I6 w/270,000 mi
1998 ZJ 5.9 w/66,000 mi Slate Black
2004 KJ w/108,000 mi
jeepjeepster is offline  
post #11 of 19 Old 06-03-2020, 04:55 AM
V8GCZJ
Registered User
 
Join Date: Sep 2018
Posts: 549
I would suspect a bad crank or cam sensor, Could be a bad coil also.
V8GCZJ is offline  
post #12 of 19 Old 06-03-2020, 11:43 AM Thread Starter
MyCarDiesAlot
Registered User
 
MyCarDiesAlot's Avatar
1996 ZJ 
 
Join Date: Feb 2020
Posts: 13
Quote:
Originally Posted by jeepjeepster View Post
When it dies, if you turn the ignition off and back on, does the check engine light come on? Have you wiggled the harness on the PCM when this happens? Or even when its running normally.

Its hard to say its the PCM but they can cause this.

How do you know the fuel is cutting out?
Its not so much the fuel is cutting out, as its not getting ignited in the cylinder then getting sent back to my exhaust. you can feel the car misfire then all the fuel combusts in the muffler. My check engine light is always on because i dont have downstream o2, but when i had it read before the problem got this horrible it did throw misfire codes. and ive wiggled all the connectors and no issue. i saw someone fixed the problem by tightening their pcm and mine was slightly loose but that didnt fix it when i tried either.
MyCarDiesAlot is offline  
post #13 of 19 Old 06-03-2020, 11:46 AM Thread Starter
MyCarDiesAlot
Registered User
 
MyCarDiesAlot's Avatar
1996 ZJ 
 
Join Date: Feb 2020
Posts: 13
Quote:
Originally Posted by V8GCZJ View Post
I would suspect a bad crank or cam sensor, Could be a bad coil also.
i suspected crank sensor at first but the shifting issue is what leads me to think pcm. if it was just misfiring id replace all my plugs, wires, and coil, but the combination of misfiring and the downshifting when i hit bumps leads me to believe the pcm may just be shorting between 2 boards, or have a loose internal solder connection or something
MyCarDiesAlot is offline  
post #14 of 19 Old 06-06-2020, 06:27 PM Thread Starter
MyCarDiesAlot
Registered User
 
MyCarDiesAlot's Avatar
1996 ZJ 
 
Join Date: Feb 2020
Posts: 13
I cleaned all of the grounds i could find (braided ground on driver's side, battery ground, ground above PCM and the the right) and my problem is still not fixed. I checked the PCM connectors as well as sending vibrations through, and no issues so I'm pretty stumped with this one. If any of you guys have insight or suggestions that haven't been said yet, please let me know.
MyCarDiesAlot is offline  
post #15 of 19 Old 06-06-2020, 07:44 PM
sldoaktree
Registered User
 
sldoaktree's Avatar
 
Join Date: May 2020
Location: las vegas
Posts: 17
Garage
for the pcm i have heard of ppl tweaking the pcm by putting something inbetween the pcm and firewall in the corner . not sure if this will help .. i havent had the issue
sldoaktree is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome