Shock mount popping - JeepForum.com
 5Likes
  • 1 Post By KiloWatts
  • 3 Post By Timo_90xj
  • 1 Post By zjosh93
 
LinkBack Thread Tools
post #1 of 9 Old 07-29-2021, 09:02 AM Thread Starter
KiloWatts
Senior Member
 
KiloWatts's Avatar
1996 ZJ 
 
Join Date: Aug 2013
Location: Philadelphia
Posts: 627
Shock mount popping

Has anyone ever experienced this? I have a popping sound coming from the top of the shock mount. There is no sound with the shock disconnected from the bottom and hanging. But when it is all connected and pressure loaded it pops when moving up and down. Makes all sorts of noise whole driving, and I can replicate it by bouncing that side (passenger) up and down. Is there some metal popping in there somehow? Or could it be the shock itself? Everything's tight up top.



Sent from my Pixel 5 using Tapatalk

KiloWatts is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 07-29-2021, 09:25 AM
HighLonesome
Web Wheeler
 
HighLonesome's Avatar
1995 ZJ 
 
Join Date: Feb 2005
Location: New Mexico
Posts: 8,619
It may be flopping about sideways. And that may have wallowed out the hole. Or the bushings could just be shot.
try these, I think they were used for UC ZJs, but not sure, they work well

https://www.4wheelparts.com/p/1990-J...?ppcfon=1&gp=1
HighLonesome is offline  
post #3 of 9 Old 07-29-2021, 09:38 AM Thread Starter
KiloWatts
Senior Member
 
KiloWatts's Avatar
1996 ZJ 
 
Join Date: Aug 2013
Location: Philadelphia
Posts: 627
Thanks, I figured it out. The fix: Take off the shock and put it back on.

Just kidding, I think maybe the top bolt was just hitting the frame in the hole. Like you said, flopping about

Should be centered in the hole.


Sent from my Pixel 5 using Tapatalk
HighLonesome likes this.
KiloWatts is offline  
 
post #4 of 9 Old 07-29-2021, 11:06 AM
HighLonesome
Web Wheeler
 
HighLonesome's Avatar
1995 ZJ 
 
Join Date: Feb 2005
Location: New Mexico
Posts: 8,619
It may keep doing it. Working it's way off center that is.
HighLonesome is offline  
post #5 of 9 Old 07-29-2021, 11:29 AM Thread Starter
KiloWatts
Senior Member
 
KiloWatts's Avatar
1996 ZJ 
 
Join Date: Aug 2013
Location: Philadelphia
Posts: 627
Quote:
Originally Posted by HighLonesome View Post
It may keep doing it. Working it's way off center that is.
Yeah it is. How annoying, heading to the parts store now

Sent from my Pixel 5 using Tapatalk
KiloWatts is offline  
post #6 of 9 Old 07-29-2021, 11:39 AM
HighLonesome
Web Wheeler
 
HighLonesome's Avatar
1995 ZJ 
 
Join Date: Feb 2005
Location: New Mexico
Posts: 8,619
The metal bushing retainers should be wider than the bushing in circumference.
HighLonesome is offline  
post #7 of 9 Old 07-30-2021, 04:01 AM
Timo_90xj
Web Wheeler
 
Timo_90xj's Avatar
1998 ZJ 
 
Join Date: Mar 2006
Location: Helsinki, Finland - on the European side of the Atlantic
Posts: 11,112
Play rock and heavy metal louder in your Jeep. It'll make that annoying pop go away.

I suggest ZZ Top in memory of Dusty Hill.

1998 Grand Cherokee 5.9 LX daily driver, 1.75" BB, 32" KM2s, HPD30 Eaton e-locker/D44a stock LSD, 4.56 gears, custom- fabbed tube bumpers and tube fenders,...


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



1990 XJ Limited (4-door), 4.0 I6, AW4, NP242, ***rolled and totalled @ 165k miles***

***Under construction***
1990 XJ (4-door), 4.0 I6, AW4, NP242, PBR 42" tires, Unimog 404 portal axles, 110" WB, full cage + uniframe completely rebuilt, front 3-link + panhard / double triangulated 4-link rear,... ***SOLD***
Timo_90xj is offline  
post #8 of 9 Old 07-30-2021, 07:29 AM
zjosh93
Registered User
1993 ZJ 
 
Join Date: Aug 2010
Location: Austin
Posts: 3,275
In that first pic the cup washer is upside down. The washer cups the bushing. That's why the bushing is pushed so far out.
Attached Images
 
HighLonesome likes this.
zjosh93 is offline  
post #9 of 9 Old 07-30-2021, 08:01 AM Thread Starter
KiloWatts
Senior Member
 
KiloWatts's Avatar
1996 ZJ 
 
Join Date: Aug 2013
Location: Philadelphia
Posts: 627
I'll be danged, it is. Still popping, so it's wasn't the hole. Starting to wonder if it's coming from inside the shock, if that's even possible. I'm taking @Timo_90xj 's advice for now.

Sent from my Pixel 5 using Tapatalk
KiloWatts is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome