Shifting issues after changing Neutral Safety Switch? - JeepForum.com
 1Likes
  • 1 Post By wsc803
 
LinkBack Thread Tools
post #1 of 5 Old 03-15-2020, 02:54 PM Thread Starter
wsc803
Registered User
 
Join Date: Jan 2019
Posts: 35
Specs: 98 ZJ Limited, 4.0 I6, 200k miles

I changed my Neutral Safety Switch yesterday because my reverse lights weren't working. I used the guide in this post: https://www.jeepforum.com/forum/f13/z...epair-3435370/

Everything went great. No ATF even came out (checked levels afterward and they're where they should be) when I removed the NSS. Reverse lights work now! Awesome, time for a beer.

...except I drive it today and I seem to have some shifting problems (or, at least, shifting is different). It seems to shift into 2nd earlier than usual (~15mph/2000rpm) with a little hiccup. Feels like it's slipping, I lose a little power, RPMs drop a few hundred, then spike a few hundred, then return to normal. I don't think there are any issues shifting into 3rd, 4th, or OD. I could be getting into my own head, but it also feels like the accelerator is much more sensitive.

It was certainly shifting much later before I changed the NSS. Of course I'm worried about potential tranny issues because I just hit 200k.

The NSS I used was just the basic one from Advance. It was a spur of the moment thing to do some Jeep work and I didn't want to wait on one in the mail. Should I just order a Mopar one?

wsc803 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 03-16-2020, 04:21 AM
Timo_90xj
Web Wheeler
 
Timo_90xj's Avatar
1998 ZJ 
 
Join Date: Mar 2006
Location: Helsinki, Finland - on the European side of the Atlantic
Posts: 10,306
NSS has nothing to do with shifts, all it does is provide backup lights when in reverse, and allows you to start when in neutral or park.

This is a separate issue, and might just be coincidence it started now, or you might've knocked loose your throttle valve cable.

1998 Grand Cherokee 5.9 LX daily driver, 1.75" BB, 32" KM2s, HPD30 Eaton e-locker/D44a stock LSD, 4.56 gears, custom- fabbed tube bumpers and tube fenders,...


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



1990 XJ Limited (4-door), 4.0 I6, AW4, NP242, ***rolled and totalled @ 165k miles***

***Under construction***
1990 XJ (4-door), 4.0 I6, AW4, NP242, PBR 42" tires, Unimog 404 portal axles, 110" WB, full cage + uniframe completely rebuilt, front 3-link + panhard / double triangulated 4-link rear,... ***SOLD***
Timo_90xj is offline  
post #3 of 5 Old 03-19-2020, 03:10 PM
mikem350
Registered User
1994 ZJ 
 
Join Date: Sep 2014
Location: Sunrise
Posts: 239
I second the TV cable!

Proud owner of two DD 4.0 ZJs
Flame Red 94 mint!
Silver 98 just hit 320k miles....runs great!
mikem350 is offline  
 
post #4 of 5 Old 03-20-2020, 08:53 AM Thread Starter
wsc803
Registered User
 
Join Date: Jan 2019
Posts: 35
Thanks! I gave a look at the TV cable a few days ago and the little white clip is gone. So... that's probably it.

Time to grab one out of the junkyard... if they're still open with all this COVID-19 stuff.
1996maroonzjf likes this.
wsc803 is offline  
post #5 of 5 Old 03-20-2020, 09:30 AM
Timo_90xj
Web Wheeler
 
Timo_90xj's Avatar
1998 ZJ 
 
Join Date: Mar 2006
Location: Helsinki, Finland - on the European side of the Atlantic
Posts: 10,306
You might want to order a new one from Rockauto, the cables stretch and can cause erratic shift behavior - costs only around 50$ and it's a Mopar part

1998 Grand Cherokee 5.9 LX daily driver, 1.75" BB, 32" KM2s, HPD30 Eaton e-locker/D44a stock LSD, 4.56 gears, custom- fabbed tube bumpers and tube fenders,...


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



1990 XJ Limited (4-door), 4.0 I6, AW4, NP242, ***rolled and totalled @ 165k miles***

***Under construction***
1990 XJ (4-door), 4.0 I6, AW4, NP242, PBR 42" tires, Unimog 404 portal axles, 110" WB, full cage + uniframe completely rebuilt, front 3-link + panhard / double triangulated 4-link rear,... ***SOLD***
Timo_90xj is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome