Random Misfire (P0300) Only in Morning When Cold - JeepForum.com
 
LinkBack Thread Tools
post #1 of 1 Old 11-18-2015, 08:39 PM Thread Starter
TRock
Registered User
1997 ZJ 
 
Join Date: Nov 2015
Posts: 2
Random Misfire (P0300) Only in Morning When Cold

97 Jeep Grand Cherokee has been misfiring only in the morning when it's cold, under 50 degrees, for about 10 minutes until it reaches operating temperature. I'm at a loss and running out of things to check & replace.

I've taken it to two repair shops and they keep telling me to replace stuff, but nothing has fixed it so far.

Here's what I've replaced:
  • New Plugs, Wires, Cap, Rotor
  • Camshaft Pos. Sensor
  • Cleaned throttle body
  • MAP sensor
  • Intake Air Temp Sensor
  • Idle Air Control Valve
  • Fresh Gas, Fuel Injector Cleaner

Trying to get this fixed before weather gets any colder, not sure the old jeep would like below freezing with this problem. Any help would be great!


Last edited by TRock; 11-21-2015 at 08:17 AM.
TRock is offline  
Reply

Tags
misfire , p0300

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome