No dashlights or tail lights - JeepForum.com
 2Likes
  • 1 Post By Boojo35
  • 1 Post By Boojo35
 
LinkBack Thread Tools
post #1 of 6 Old 10-15-2021, 09:07 PM Thread Starter
4xphate
Registered User
 
4xphate's Avatar
1994 ZJ 
 
Join Date: Apr 2017
Posts: 174
Garage
No dashlights or tail lights

My blinker lights work on dash and bright light. No tail lights but brake lights work. Just happened this morning, any ideas? My electrical knowledge sucks.
1994 grand cherokee

4xphate is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 10-15-2021, 10:10 PM
Boojo35
Web Wheeler
1987 YJ Wrangler 
 
Join Date: Jul 2007
Location: Beer City
Posts: 3,439
Garage
Check your fuses first. That will lead you down the first path. Dash and tail are a shared fuse in most vehicles.
4xphate likes this.

If you cannot fix it with a hammer then it has to be an electrical problem.
Boojo35 is offline  
post #3 of 6 Old 10-15-2021, 10:25 PM
tvengineer
Registered User
1993 ZJ 
 
Join Date: Jun 2010
Location: Winston Salem
Posts: 19
Could be the ignition switch. I had a similar problem with my 93 GC and turned out to be contacts in the ignition key switch.
tvengineer is offline  
 
post #4 of 6 Old 10-15-2021, 10:57 PM
Boojo35
Web Wheeler
1987 YJ Wrangler 
 
Join Date: Jul 2007
Location: Beer City
Posts: 3,439
Garage
Quote:
Originally Posted by tvengineer View Post
Could be the ignition switch. I had a similar problem with my 93 GC and turned out to be contacts in the ignition key switch.
Please tap out right now. Dash and tail lights are powered by B+ which means hot at all times. It has nothing to do with the ignition switch.
4xphate likes this.

If you cannot fix it with a hammer then it has to be an electrical problem.
Boojo35 is offline  
post #5 of 6 Old 10-16-2021, 09:09 AM Thread Starter
4xphate
Registered User
 
4xphate's Avatar
1994 ZJ 
 
Join Date: Apr 2017
Posts: 174
Garage
Is there another fuse box other than under hood and under glovebox? All those look good, it wouldnt be a relay would it? Found it, was #12. Thanks man.
4xphate is offline  
post #6 of 6 Old 10-18-2021, 04:59 PM Thread Starter
4xphate
Registered User
 
4xphate's Avatar
1994 ZJ 
 
Join Date: Apr 2017
Posts: 174
Garage
Yeah, I made it less than 1/4 mile before blew again. I believe its my headlight switch for anyone searching this subject. It will be in tomorrow, if I dont update that was it.
4xphate is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome