JeepForum.com

JeepForum.com (https://www.jeepforum.com/forum/)
-   ZJ Grand Cherokee Forum (https://www.jeepforum.com/forum/f13/)
-   -   My 5.2 Build Thread (https://www.jeepforum.com/forum/f13/my-5-2-build-thread-1512870/)

ZJNewbi3 10-21-2013 01:57 PM

Quote:

Originally Posted by Scopez (Post 17022122)
I need to find a good crimper so I can put lugs on all my ends. Any suggestions? Or were you able to just leave the wire exposed and screw it down tight?

I left them exposed and bolted them down tight then sprayed some seal stuff on it.

ZJNewbi3 10-21-2013 07:58 PM

2 Attachment(s)
Here are some pictures of the new terminals. Sorry about the stupid flash glare...

Myusername1674 10-22-2013 12:36 AM

I just did the same thing to my battery terminals, only $5 at O-Reillys. The factory terminals had shredded. haha those quick discos look nice though, I didn't get that.

ZJNewbi3 10-22-2013 07:46 AM

Quote:

Originally Posted by Myusername1674 (Post 17041810)
I just did the same thing to my battery terminals, only $5 at O-Reillys. The factory terminals had shredded. haha those quick discos look nice though, I didn't get that.

I think mine were around $7 with tax. Now I can't wait til I can get an Optima Yellow Top!

PolkaPower 10-22-2013 09:06 AM

I would skip the Optima since the price is still the same even though they are made in Mexico now. Sears makes some very nice AGM batteries though.

ZJNewbi3 10-22-2013 03:50 PM

Quote:

Originally Posted by PolkaPower (Post 17048682)
I would skip the Optima since the price is still the same even though they are made in Mexico now. Sears makes some very nice AGM batteries though.

I'll be waiting a very long time for this to happen anyway xD the Die Hard is only a little over one year old.

ZJNewbi3 11-02-2013 04:08 PM

Replaced the tranny pan filter with a WIX and gasket with Fel-Pro (no RTV). Also gave the pan a nice cleaning. Hopefully this stops all leaking! So far so good! Cross your fingers for me!

moparlover1992 11-02-2013 06:42 PM

Good luck I always hate trans pan leaks. On mine I dropped the pan multiple times before realizing the quick disconnect fittings that tap into the tranny that the tranny cooler lines hook to were leaking. Replaced those and so far so good. Just something to keep ur eye on

Sent from my Galaxy Note 3 using JeepForum

95GCL 11-03-2013 06:51 AM

Quick question: Did you have to do the trimming on the front bumper? Was there rubbing?

ZJNewbi3 11-03-2013 07:19 AM

Quote:

Originally Posted by 95GCL (Post 17389378)
Quick question: Did you have to do the trimming on the front bumper? Was there rubbing?

Nope didn't have to. My tires aren't big enough to rub. They are 235/75/15 which is around 28" in diameter. They are still within stock spec. (225-245) Hopefully down the road I will get 30s on 15s/16s

95GCL 11-03-2013 09:01 AM

Oh haha I had looked at another users pictures thinking they were yours. Do you have pictures of the stock sized tires with 2" bb? I have stock tires and want to bb (might buy 1.75" spacer ) but it would be some time before I can buy tires

ZJNewbi3 11-03-2013 10:38 AM

Quote:

Originally Posted by 95GCL (Post 17392650)
Oh haha I had looked at another users pictures thinking they were yours. Do you have pictures of the stock sized tires with 2" bb? I have stock tires and want to bb (might buy 1.75" spacer ) but it would be some time before I can buy tires

Yup go to page 6 and there will be one there! If u want a better one ill take some when I'm home

95GCL 11-03-2013 10:57 AM

Found it! Haha lots of wheel gap!

ZJNewbi3 11-03-2013 12:00 PM

Quote:

Originally Posted by 95GCL (Post 17395562)
Found it! Haha lots of wheel gap!

I totally agree! But those tires were a graduation gift from my parents so Id feel bad sellin em off.

ZJNewbi3 11-03-2013 01:57 PM

Got home from work today and checked the pan. Found some slow drips :( I wiped around the pan edge and got some red. Decided to grab the torque wrench and check the torque. I didn't budge the dial AT ALL and all of those bolts needed at least one full turn to be 12.5ft-lbs. The temperature got to a little below forty last night, then back up to fifty today, let alone the tranny warming up to high temperatures driving at 50mph. I'm assuming this is normal, and hopefully that is the reason it was leaking.


The time now is 10:43 AM.

Powered by vBulletin Version 3.8.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.