Fuel light on and gas on E when there is gas in the tank? - JeepForum.com
 
LinkBack Thread Tools
post #1 of 9 Old 01-22-2011, 11:22 AM Thread Starter
adaptapter
Registered User
 
Join Date: Jan 2011
Location: Mtown
Posts: 1
Fuel light on and gas on E when there is gas in the tank?

Hello everyone. I just bought a 98 ZJ Laredo 5.2L and twice when I am in park the gas meter went on E and the fuel light came on when I know my tank was over half full. It went away right when I started driving so I am wondering what the cause could be? I do have a CEL on for emissions so maybe it could be related? Thank you.


Don

adaptapter is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 01-22-2011, 11:55 AM
Coolcatracing
Registered User
2008 JK Wrangler 
 
Join Date: Nov 2010
Location: Honolulu
Posts: 845
Sounds like either your sender in th tank is bad or you have a short on the signal wire. I believe a total ground on that circuit reads empty, if it's the other way around then you may have a loose connection or broken wire.

08 Unlimited Rubicon 6 speed, 315/70-16 Kelly TSR, 1.5" Spidertrax spacers factory Moab's, Rubicon Express Flex arm 3.5" lift, Smittybilt XRC front bumper with D-rings, Body Armor Extreme rock slider steps, AEV snorkel, trimmed fender flares, Hella 8" HID driving lights
Coolcatracing is offline  
post #3 of 9 Old 01-22-2011, 03:34 PM
Trizunky
Registered User
1998 ZJ 
 
Join Date: Oct 2010
Location: Sonora
Posts: 7
I have this happen to me a couple of times also. LOL the first time it happened to me I thought someone had robbed my tank.
Just turn off engine and restart and it goes away. Not a cure but I really dont have the cash to mess with it.
Trizunky is offline  
 
post #4 of 9 Old 01-22-2011, 04:58 PM
93GurblackZJ
Registered User
2000 XJ Cherokee 
 
Join Date: Oct 2010
Location: Cleveland
Posts: 69
Fuel level sensor is junk, has seen this quite a few times. Only fix I believe is to throw a new pump in it, which involves a little bit of work and an expensive part. I would keep an eye on it and if vehicle performance or gas mileage drop or you notice something just isn't right its time for the pump to go.

93 Wooped Multicolored ZJ, Sold
96 Super Clean ZJ, favorite truck ever. Lost fight with a pole, totaled. Sold
00 Black XJ, Headgasket failure victim, Rage roof rack, Bumper Hella 500's and Rear Cb antenna. 3 Inch rear lift and 2 Inch front lift. 31 Inch Firestone Destination A/T's
93GurblackZJ is offline  
post #5 of 9 Old 01-22-2011, 09:13 PM
ratmonkey
R.I.P.
 
ratmonkey's Avatar
1997 ZJ 
 
Join Date: Dec 2006
Posts: 19,809
Every chrysler product from the 90's-2000's does this. A new sending unit doesn't totally fix it.

'97 zj 5.2, some stuff, some other suff, and some things that even work sometimes.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

ratmonkey is offline  
post #6 of 9 Old 01-22-2011, 11:02 PM
newfieZJ
Registered User
 
newfieZJ's Avatar
1995 ZJ 
 
Join Date: May 2008
Posts: 6,560
Quote:
Originally Posted by ratmonkey View Post
Every chrysler product from the 90's-2000's does this. A new sending unit doesn't totally fix it.
I must not be looking when it happens to me

1995 Orvis build

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1988 MJ build

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1998 Slate 5.9 build

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1998 Platinum 5.9 build

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
newfieZJ is offline  
post #7 of 9 Old 01-22-2011, 11:14 PM
indredsnake99
Registered User
 
indredsnake99's Avatar
1998 ZJ 
 
Join Date: Sep 2008
Location: wakefield
Posts: 1,425
Quote:
Originally Posted by ratmonkey View Post
Every chrysler product from the 90's-2000's does this. A new sending unit doesn't totally fix it.
what parts are involved in fixing this since it happens on my jeep and drives me carzy and i want this annoying problem fixed

Wayne
1997 formerly GREEN now rustoleum bed lined zj 4.0 np242 bought 9/25/2008
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
gone
1998 5.9l platnium zj np249 k&n sct bought 4/6/2010
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2007 sahara 2 door wrangler stock bought 02/08/2011




To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Quote:
Originally Posted by ZJones View Post
You'll learn a lot. I didn't know anything when I first joined this site either. (not sure if that's changed at all :laugh:)
indredsnake99 is offline  
post #8 of 9 Old 01-22-2011, 11:18 PM
94chb
Registered User
 
94chb's Avatar
1989 YJ Wrangler 
 
Join Date: Dec 2009
Location: Whitwell
Posts: 1,921
my previous 97 zj if the gas level was below half a tank the gauge would read E, my new 98 would just goto E for no reason at anytime and gas light would come on, not long ago my pump died on me, 186$ and i changed it in a church parking lot, its been workin perfect since. funny thing is i sold a rear end to a guy for $200 and delivered it. as soon as i got there and delivered it and got paid my pump went out, so we both had to work on our zj's in a parking lot side by side. his rear end blew out, literally, it had 2 holes in the housing and had caught fire when he was driving it to work.
94chb is offline  
post #9 of 9 Old 01-23-2011, 12:14 AM
aircruiser
Registered User
 
aircruiser's Avatar
1996 XJ Cherokee 
 
Join Date: Jun 2006
Location: minnesota
Posts: 9,771
Quote:
Originally Posted by indredsnake99 View Post
what parts are involved in fixing this since it happens on my jeep and drives me carzy and i want this annoying problem fixed
it happened on my xj..if you are lucky enough, it just popped off the mount on the fuel pump. im not sure if you can replace it as just the part or if you have to get a whole new pump but its a little chip on the side of the pump in the tank

1996 XJ on 36" TSLs, 4", locked F/R, stretched
aircruiser is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Fuel Gauge Needle is dead... Low Fuel Light always on... any ideas? 95_JGC ZJ Grand Cherokee Forum 20 03-30-2015 09:30 PM
Fuel tank is only filling to 3/4 of a tank bammers85 WK Grand Cherokee & XK Commander Forum 11 12-11-2009 08:23 AM
WK 05 fuel spill via fuel tank juanowk05 WK Grand Cherokee & XK Commander Forum 0 11-26-2008 07:36 AM
Fuel Pump/Fuel Tank Problem ma-usa1 ZJ Grand Cherokee Forum 18 04-09-2008 07:28 PM
Fuel Pump/Fuel Tank Problem ma-usa1 ZJ Grand Cherokee Forum 0 02-05-2003 06:02 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome