97 zj 4.0 stumble sputter, backfire and stall - JeepForum.com
 
LinkBack Thread Tools
post #1 of 6 Old 05-27-2020, 11:37 AM Thread Starter
Rldsl
Registered User
 
Join Date: Jan 2020
Posts: 40
97 zj 4.0 stumble sputter, backfire and stall

My 97 4.0 auto trans got ac load of watered down gas a couple of weeks ago. I coughed it through with some dri- gas , but then it started acting up. ( no codes ) And randomly sputtering. I replaced the TPS, IAC and ignition coil and started running great. Took off this morning. went about 70 miles and when getting on the freeway it sputtered coughed and died and refused to start. Drained the batt. Mile round trip walk to get a new batt ,( it was due anyway) shot some ether and fired, went about 4 miles, sputter, backfire ( scared the crap out of a trooper on the side of the rd ) and stall. Swapped out the old ignition coil on a whim. It fired, but had to drive in 2nd gear and keep the rpms up. Shifting to drive would stumble and try to stall. . Limped it all the way home this way ,and picked Up a CPS just for giggles on the way home.. the thing did throw an O2 sensor code on my son the other day , but he drives like a 90 year old woman, and tends to load things. Any suggestions, I'm all ears. Thanks.

Rldsl is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 05-27-2020, 12:26 PM Thread Starter
Rldsl
Registered User
 
Join Date: Jan 2020
Posts: 40
Update: I also just ordered a couple of O2 sensors and a relay for them just for giggles.
Rldsl is offline  
post #3 of 6 Old 05-27-2020, 01:13 PM
jtec
Registered User
 
jtec's Avatar
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 9,848
MIGHT WANT TO tell us what codes there are or were, maybe a fuel pressure test.

Do you have a scanner - we could check all codes and look at live data.

o2 sensors are a messenger don't shoot the messenger - ok maybe you do but not the first thing.

Normal driving esp with an automatic should NOT load anything up.

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
 
post #4 of 6 Old 05-27-2020, 03:16 PM Thread Starter
Rldsl
Registered User
 
Join Date: Jan 2020
Posts: 40
I had mentioned. no codes. Going to have to do some digging to find my fuel pressure gauge set..
Rldsl is offline  
post #5 of 6 Old 05-27-2020, 06:16 PM Thread Starter
Rldsl
Registered User
 
Join Date: Jan 2020
Posts: 40
Well, fuel pressure is a steady 46 lbs, but that no codes bit.... now it's really no codes, as in it's not even powering up the code reader( and yes, I double checked the code reader function on my son's jeep) am I looking at a bum computer here or is there a protection device inline? Or???
Rldsl is offline  
post #6 of 6 Old 05-27-2020, 09:04 PM Thread Starter
Rldsl
Registered User
 
Join Date: Jan 2020
Posts: 40
The fun continues. I unplugged/ replugged everything I could find, now getting code reader function. Now getting a code for the coil. And one for lean condition bank 1
Rldsl is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome