97 Grand Cherokee Lerado A/C issue - JeepForum.com
 1Likes
  • 1 Post By jtec
 
LinkBack Thread Tools
post #1 of 8 Old 07-25-2021, 09:45 PM Thread Starter
baddmove
Registered User
 
baddmove's Avatar
1997 ZJ 
 
Join Date: Apr 2012
Location: Pullman
Posts: 7
97 Grand Cherokee Lerado A/C issue

So the other day I had to go to Spokane and it was nice in the morning so no A/C needed at first but as it warmed up I turned it on low and eventually to high, all was fine.
I start to come back to my town , about 80 miles away and no A/C at all, nothing. Well, it was a pretty hot ride except I could put the A.C on normal (not recirculate) and I could feel cold air coming in. 2 days later I get in to go to the store and A/C is working fine again . I get out of the store to come home and nothing again, no fan, but I can feel cold air.

I checked all the fuses and they are good. Went and bought a new Blower motor relay and not really sure where it goes as almost all YT videos I watched everyone just skips anything about a relay and goes straight to the resistor.

I haven't checked the resistor yet but do any of you think it's the blower relay and if so, where does it go? it's a little grey square with 5 pins- MasterPro 2ER13. I tested the fan at 12V and it works nice and strong.

baddmove is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 07-25-2021, 10:39 PM
jtec
Registered User
 
jtec's Avatar
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 10,446
I am trying to get you worked thru this -

https://www.jeepforum.com/forum/f11/.../#post41321045

FYI the relay is for ATC. You have Manual temp system.
baddmove likes this.

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
post #3 of 8 Old 07-26-2021, 08:01 AM
LouC
Registered User
2007 WK 
 
Join Date: Feb 2008
Location: NY
Posts: 3,034
Do a search on this, there is a connector under the dash right under the glove box that overheats and causes intermittent loss of fan function. You can wire around the bad connection and make it work again. Jiggle the connection and you might hear the fan go on.

2017 JK Unlimited Sport 6 spd
2007 WK Limited Hemi QDII
1998 ZJ Laredo 4.0 Selectrac
LouC is offline  
 
post #4 of 8 Old 07-26-2021, 08:08 AM Thread Starter
baddmove
Registered User
 
baddmove's Avatar
1997 ZJ 
 
Join Date: Apr 2012
Location: Pullman
Posts: 7
Thanks Jtec and LouC. What does this look like LouC? I have the glove box out and it's going to be in the 90's all week. I first thought it was related to turning the key on so that got me kind of confused. I can use a Multi meter so we're good there. I'll check back in after work (5pm) and thanks again.
baddmove is offline  
post #5 of 8 Old 07-26-2021, 10:51 AM
LouC
Registered User
2007 WK 
 
Join Date: Feb 2008
Location: NY
Posts: 3,034
hope that helps. Get a bright led flashlight so you can see under there.
Attached Thumbnails
ZJ blower motor harness repair.jpg  

2017 JK Unlimited Sport 6 spd
2007 WK Limited Hemi QDII
1998 ZJ Laredo 4.0 Selectrac
LouC is offline  
post #6 of 8 Old 07-26-2021, 04:32 PM
RedRiverT
Registered User
1997 ZJ 
 
Join Date: Nov 2014
Posts: 761
Also, see post #9 in this thread:

https://www.jeepforum.com/forum/f13/...sistor-872458/
RedRiverT is offline  
post #7 of 8 Old 07-26-2021, 09:53 PM Thread Starter
baddmove
Registered User
 
baddmove's Avatar
1997 ZJ 
 
Join Date: Apr 2012
Location: Pullman
Posts: 7
Ok, Thanks all, I'll start with that connection. I'll get back and let you all know as soon as I get to it, been busy at work.
baddmove is offline  
post #8 of 8 Old 08-01-2021, 11:07 AM Thread Starter
baddmove
Registered User
 
baddmove's Avatar
1997 ZJ 
 
Join Date: Apr 2012
Location: Pullman
Posts: 7
So I got a chance to look into the harness today and nothing, it looks fine in there and the blower is working again all of a sudden. I guess I will just keep and eye on it and when it cools down here a bit i might just by-pass the wire any way.
baddmove is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome