96 ZJ, Cranks, no spark or fuel - JeepForum.com
 
LinkBack Thread Tools
post #1 of 9 Old 11-05-2019, 04:03 PM Thread Starter
downs
Registered User
 
downs's Avatar
1995 XJ Cherokee 
 
Join Date: Oct 2018
Location: Hunt County
Posts: 600
Garage
96 ZJ, Cranks, no spark or fuel

1996 ZJ. 5.2L V8. No security light on dash. Grounded purple/yellow wire under driver's kick panel. If I hotwire the spot where the ASD relay is I can get injectors to open and get 12V to the ignition coil (you can hear fuel pressure bleed off), and if I hotwire the spot where the fuel pump relay is I can get the fuel pump to run.

However with known good relays in place we can't get any spark or fuel when we crank. It'll crank all day just won't start. We figured it was security system but if that's the case we can't get it to disarm no matter what tricks we try.

I'm unsure on what to do at this point. Owner (not me) is close to offloading it but if it's something simple we're overlooking we want to try it since he put a transmission in it right before it stopped running.


1995 Jeep Cherokee Country 4X4 Stock
AW4/NP231/C8.25/D30/"UpCounty" suspension
downs is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 11-05-2019, 08:00 PM
RedRiverT
Registered User
1997 ZJ 
 
Join Date: Nov 2014
Posts: 677
Crankshaft Position Sensor gives the signal to the PCM for when to trigger the coil. Camshaft Position Sensor ("Pickup Coil", the thing in the distributor) gives the signal to the PCM for when to trigger the injectors. If the PCM is bad, or maybe an electrical ground or connection is bad, it won't trigger them.

I saw a YouTube video where the ASD relay wasn't letting it start and the guy found an electrical short in a wire rubbed against the front of the engine. I think it was an O2 sensor wire. Oh yeah, a common gremlin is the O2 sensor wires rubbing through against the exhaust or driveshaft.

You could try these things:
https://www.jeepforum.com/forum/f13/...talls-1407423/
RedRiverT is offline  
post #3 of 9 Old 11-05-2019, 10:26 PM Thread Starter
downs
Registered User
 
downs's Avatar
1995 XJ Cherokee 
 
Join Date: Oct 2018
Location: Hunt County
Posts: 600
Garage
CPS checks good on multimeter per manual. The fuel pump wont prime when you turn the key to on but the pump does work. Ill have them check the O2 wires.

That link you posted Just takes me to a forum.suggestions page. Ill try it from a real.computer later.


Sent from my SM-G892A using Tapatalk

1995 Jeep Cherokee Country 4X4 Stock
AW4/NP231/C8.25/D30/"UpCounty" suspension
downs is offline  
 
post #4 of 9 Old 11-06-2019, 04:41 AM
V8GCZJ
Registered User
 
Join Date: Sep 2018
Posts: 602
If the asd relay is not working nothing else will. Do you see the check engine light come on when you turn the key to on? If not there is an issue with the pcm or it's not getting power.
V8GCZJ is offline  
post #5 of 9 Old 11-06-2019, 05:19 AM Thread Starter
downs
Registered User
 
downs's Avatar
1995 XJ Cherokee 
 
Join Date: Oct 2018
Location: Hunt County
Posts: 600
Garage
No check engine light. For some reason my OBD2 reader will say "connecting" and will not go past that point. Bad connection at the computer would make sense in that case.

1995 Jeep Cherokee Country 4X4 Stock
AW4/NP231/C8.25/D30/"UpCounty" suspension
downs is offline  
post #6 of 9 Old 11-17-2019, 04:19 PM
theo749
Registered User
 
Join Date: Nov 2019
Posts: 4
sounds like the exact same problem im having with my 93zj 5.2l limited. srarted with the alarm tripping with a bad battery, replacing the battery let me shut the alarm of but still no start. i have crank, no fuel pump. i still need to test for spark but haven't got around to it yet. also no cel light on mine. have you had any luck yet? if you figure it out id like to know what worked. i swapped out my pcm with a used one from a 94 5.2l laredo, i figured it was close enough to my 93, but it didnt fix it, just made the symptoms slightly different. i have no clue if that ecm ever worked though for all i know it could have bad caps
theo749 is offline  
post #7 of 9 Old 11-18-2019, 03:05 PM Thread Starter
downs
Registered User
 
downs's Avatar
1995 XJ Cherokee 
 
Join Date: Oct 2018
Location: Hunt County
Posts: 600
Garage
Still no joy.

Sent from my SM-G892A using Tapatalk

1995 Jeep Cherokee Country 4X4 Stock
AW4/NP231/C8.25/D30/"UpCounty" suspension
downs is offline  
post #8 of 9 Old 08-11-2020, 12:54 AM
mota32gd
Registered User
 
mota32gd's Avatar
1998 ZJ 
 
Join Date: Jan 2014
Location: Winder
Posts: 9
Thanks

Great write up. simle terms but complete.

Bad beats make winning sweet and my kids mind me.
mota32gd is offline  
post #9 of 9 Old 08-16-2020, 11:21 PM
mpgmike
Registered User
 
mpgmike's Avatar
1995 ZJ 
 
Join Date: Aug 2020
Location: Sussex
Posts: 10
Garage
Don't forget to check fuses. If the scan tool won't connect, you may have a blown fuse somewhere. There are fuses both under the hood and in the passenger's front door jamb (base of the A pillar).
mpgmike is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome