'96 4.0 destroying cats.... - Page 2 - JeepForum.com
 4Likes
Reply
 
LinkBack Thread Tools
post #16 of 32 Old 02-14-2020, 10:08 PM Thread Starter
pinto_dave
Registered User
1996 ZJ 
 
Join Date: Oct 2015
Location: Boise
Posts: 135
Here are the upstream (O2S11(V)) and the downstream (O2S12(V)) O2 sensor readings from the same trip.

This was from a 3 minute capture. Where the downstream drops to around the 0.079v and hangs out there, that's where I stopped at a stoplight. The rest is from traveling speeds up to 35mph and maintaining speed as much as possible.

I also included the short and long fuel trim readings from that trip, if it helps

Attached Thumbnails
Upstream.jpg   Downstream.jpg   Short_trim.jpg   Long_trim.jpg  

1996 Grand Cherokee - 5.9 Limited Moss Green Poser

5.9 Limited Body and Interior Parts
pinto_dave is offline  
Sponsored Links
Advertisement
 
post #17 of 32 Old 02-15-2020, 12:06 AM
rep-tile
Cash 4 clunkers survivor
 
rep-tile's Avatar
2004 WJ 
 
Join Date: Jul 2013
Location: bakersfield
Posts: 1,535
You can't possibly go through that many cats without dumping so much fuel that it wouldn't be runnning or at least running so much like crap that it'd be barely driveable.

96 ZJ alone is around the years that are screaming computer issues, but do inspect the O2 sensors wiring for shorts.

04 WJ 4.0 - Avital 4103, DB-ALL
91 XJ 4.0 - Avital 4103, Stage-2 aFe intake system, BBK high flow Throttle Body, 703s injectors, Jones Exhaust A3518M-5
rep-tile is offline  
post #18 of 32 Old 02-15-2020, 10:32 AM
V8GCZJ
Registered User
 
Join Date: Sep 2018
Posts: 529
By the looks of this and the cap you posted i would say the fuel sync is off.


20200214_120731_1581709445755.jpg


Spark happens when the rotor is at the end or beginning of rotation when it's lined up with the insert in the cap instead of in the middle.
V8GCZJ is offline  
 
post #19 of 32 Old 02-15-2020, 10:46 AM Thread Starter
pinto_dave
Registered User
1996 ZJ 
 
Join Date: Oct 2015
Location: Boise
Posts: 135
The car idles great, drives fine, maybe some slight sluggishness at times, which is why this is so baffling.

So with fuel sync being off, that tells me these possibilities...

Injectors
CMP
CKP
Timing
PCM
Wiring

1996 Grand Cherokee - 5.9 Limited Moss Green Poser

5.9 Limited Body and Interior Parts
pinto_dave is offline  
post #20 of 32 Old 02-17-2020, 10:06 AM
MrRoundel
Registered User
1998 ZJ 
 
Join Date: Jan 2007
Location: California
Posts: 2,453
That burn seems a bit too far off center for my liking. Timing issue is possible, IMHO. While it's possible that your getting a good spark conduction with that position, there's not a lot of tolerance for advance/retard errors. Does your live monitoring show timing? I think mine showed at 6 degrees BTDC minimum and a 14.22 mean degrees BTDC. This was at idle from a cold start. As luck would have it, I didn't get the maximum in the frame when I took the image of the readout. Good luck.

1998 Laredo 4.0L 4x4, 242 TC. Turned over 200K miles in 06/18. Original owner.
MrRoundel is online now  
post #21 of 32 Old 02-17-2020, 10:19 AM
zjosh93
Registered User
1993 ZJ 
 
Join Date: Aug 2010
Location: Austin
Posts: 2,956
MrRoundel brings up a good point. If it's firing that far to one edge it could start to crossfire at times. You can check the distributor sync on the 4.0 pretty easily. And you can check rotor phasing by drilling/cutting a hole on a spare/old cap so you can see where the rotor is pointing when it fires. Not much you can do about it on the 4.0 though. I've made small adjustments by carefully bending the alignment tab on the rotor.
zjosh93 is offline  
post #22 of 32 Old 02-17-2020, 09:36 PM Thread Starter
pinto_dave
Registered User
1996 ZJ 
 
Join Date: Oct 2015
Location: Boise
Posts: 135
What exactly do you mean by checking distributor sync? Do you mean by checking to see if it is indexed correctly?

I pulled the distributor, played with the rotor positioning, and the existing install was the only way that I could get it to fire and run. I did notice that the rotor was pointing in the 6'oclock position, instead of 5, like the manual states, but I cannot adjust any of this, since the rotor/shaft always defaults to the 6 position when installing with a punch/dowel to line up the sync ring to the distributor body, locks it into that position.

My assumption is, that the PCM compensates for it being this far off by advancing/retarding the timing, or is this too much for the PCM to try to adjust for?

I am going to trace the O2 sensor wiring tomorrow to be sure it is healthy, and I have new battery cables coming. I will try swapping in an aesthetically better PCM once I get the new battery cables put together, and the O2 sensor wiring tested. I don't want to fry a PCM from a short or a bad ground.

I am getting ignition advance of 14 - 20, usually sitting around 17 degrees, at idle, from cold start.

Here is an old cap with a hole cut in it, so you can see how far away it is, past the #1 post.

This is the Spectra CH15 new replacement distributor from O'Reilly Auto Parts.
Attached Thumbnails
20200217_165237.jpg   20200217_165149.jpg  

1996 Grand Cherokee - 5.9 Limited Moss Green Poser

5.9 Limited Body and Interior Parts
pinto_dave is offline  
post #23 of 32 Old 02-17-2020, 10:11 PM
Timo_90xj
Web Wheeler
 
Timo_90xj's Avatar
1998 ZJ 
 
Join Date: Mar 2006
Location: Helsinki, Finland - on the European side of the Atlantic
Posts: 10,400
Quote:
Originally Posted by pinto_dave View Post
I pulled the distributor, played with the rotor positioning, and the existing install was the only way that I could get it to fire and run. I did notice that the rotor was pointing in the 6'oclock position, instead of 5, like the manual states, but I cannot adjust any of this, since the rotor/shaft always defaults to the 6 position when installing with a punch/dowel to line up the sync ring to the distributor body, locks it into that position.
Have you done a side-by-side comparison between your original distributor and replacement for alignment differences? As for dizzy itself, oil pump shaft/ distributor shaft/ distributor needs to be lined-up correctly for #1 cylinder at compression stroke TDC; here's from a '94 FSM for the 4.0, but I'm pretty sure it's the same for '96-'98 ('99 for the XJ and TJ)


1998 Grand Cherokee 5.9 LX daily driver, 1.75" BB, 32" KM2s, HPD30 Eaton e-locker/D44a stock LSD, 4.56 gears, custom- fabbed tube bumpers and tube fenders,...


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



1990 XJ Limited (4-door), 4.0 I6, AW4, NP242, ***rolled and totalled @ 165k miles***

***Under construction***
1990 XJ (4-door), 4.0 I6, AW4, NP242, PBR 42" tires, Unimog 404 portal axles, 110" WB, full cage + uniframe completely rebuilt, front 3-link + panhard / double triangulated 4-link rear,... ***SOLD***
Timo_90xj is offline  
post #24 of 32 Old 02-17-2020, 10:33 PM Thread Starter
pinto_dave
Registered User
1996 ZJ 
 
Join Date: Oct 2015
Location: Boise
Posts: 135
I did just that tonight.

The replacement Spectra has the rotor head almost exactly past the #1 post when installed and "aligned". Maybe a hair more than "past the post".

The original has the trailing edge of the rotor head aligned with the #1 post.



I may have stumbled upon the answer though....

I think I'm running a 180 degree thermostat. I don't remember why, maybe the parts house sold it to me when I asked for the OEM replacement, maybe they have it listed wrong? I know that the temp gauge and the scan tool both report 180 once up to operating temp, all of the time. I think this would explain the fuel consumption, which in turn helps to understand the catalytic converters lasting less than a year....

I will check on the thermostat that I purchased tomorrow. I have all of the new motor documentation at my new place, and in the middle of moving right now...

1996 Grand Cherokee - 5.9 Limited Moss Green Poser

5.9 Limited Body and Interior Parts
pinto_dave is offline  
post #25 of 32 Old 02-18-2020, 08:03 AM
zjosh93
Registered User
1993 ZJ 
 
Join Date: Aug 2010
Location: Austin
Posts: 2,956
It's actually supposed to be slightly past the #1 post. It's in the FSM pages Timo posted. The 4.0 distributor has 14 teeth so as long as you are within 13 degrees of perfect, that's as good as you can make it. (360 degrees / 14 teeth / 2 for offset = 12.9 degrees)

This seems like a decent write up:
https://tomasz.korwel.net/2006/12/19...omment-page-1/

IMS the 180 degree thermostat won't make it stay in open loop. The 4.0 seems to do better with a hotter thermostat though so it might be worth swapping out.
zjosh93 is offline  
post #26 of 32 Old 02-18-2020, 09:37 AM Thread Starter
pinto_dave
Registered User
1996 ZJ 
 
Join Date: Oct 2015
Location: Boise
Posts: 135
So the distributor should be okay, timing looks good then.

The pcm doesn't stay in open loop, it switches to closed shortly after running as it should, I'm wondering if it slowly running richer because of it staying pegged at 180 has degraded the cat all these times, though.

I'll post back tonight with the results of the wiring check

1996 Grand Cherokee - 5.9 Limited Moss Green Poser

5.9 Limited Body and Interior Parts
pinto_dave is offline  
post #27 of 32 Old 02-18-2020, 06:49 PM
DavesJeep101
Registered User
 
Join Date: Feb 2020
Posts: 23
One question, has only one cat actually melted? That is definitely caused by oil, over fueling or a misfire.

Maybe yes, you had a problem before that made the cat fail but in rare cases cat codes can be false. Exhaust leaks near the rear O2 can do it and even the notorious 4.0 manifold when it gets bad. To properly diag you really need to have a scanner to watch the rear (and front) ) 02 signal, should be mostly flat. When it starts switching like the front O2 you get P0420. Also you need to make sure fuel trims are good.

I replaced manifolds on several Cadillacs, I think from 2005-2008 due to pinhole cracks you could not even see around the bung for the O2. It was swirling air around the O2 setting P0420, PO430.

And yes, STAY AWAY from Bosch O2 sensors.
DavesJeep101 is offline  
post #28 of 32 Old 02-18-2020, 10:28 PM Thread Starter
pinto_dave
Registered User
1996 ZJ 
 
Join Date: Oct 2015
Location: Boise
Posts: 135
Yes, the last cat that was run on the old motor was actually melted half through. I replaced the cat on the new motor a week after dropping it in. This is the first cat failure on the new motor.

I'm not finding any exhaust leaks. The O2 is fluctuating like the front O2 is, and during cruise it spends most of the time within 1v of the upstream sensor.

I'm seriously thinking the fuel trims are off, and it may be the fuel sync as mentioned earlier. I spoke with the dealership today, and they also validated that it needs the sync set done with the new distributor. Their charge is $202 pre tax, does this sound accurate?

1996 Grand Cherokee - 5.9 Limited Moss Green Poser

5.9 Limited Body and Interior Parts
pinto_dave is offline  
post #29 of 32 Old 02-19-2020, 09:09 AM
dstober
Registered User
 
Join Date: Oct 2018
Posts: 2
You said you rebuilt the injectors. How did you do that? I share an experience recently from my garage that might help you. My son's best buddy has a 95 wrangler with 2.5 4cyl manual transmission. Last fall the engine threw a rod through the side of the block. We just finished replacing it with a rebuilt long block. There were several issues that had to be sorted out to get it to run right. You mention it seems sluggish. Double check the distributor installation. There is a special procedure on this 2.5 to install the distributor and we were 1 tooth off which resulted in retarded ignition timing. It seemed to run a bit sluggish and sometimes would start normally and sometimes not start at all with other intermittent symptoms not usually associated with retarded ignition timing. At idle you should be able to put a timing light on it and see timing somewhere around 10 degrees before TDC being controlled by the ECU. Also we took the injectors to a shop in Salt Lake City that specifically services injectors. All 4 of our injectors had bad spray patterns. We got back a sheet showing flow pattern etc before and after. Made the jeep run a lot better. The ECU is trying to control the amount of fuel by varying the on time of the injectors but it assumes the correct spray pattern and flow rate. It could be trying to increase the amount of fuel overall based on O2 readings but some cylinders could be passing a lot of unburned fuel out due to poor atomization hence excess fuel melting the cat. I don't know what you have available in Boise but here is the info to the shop in Salt Lake City. Master Tech, 1717 South State Street, Salt Lake City, 801-485-1212. Their website is fuelinjectionutah. Our experience with these guys was very professional and I highly recommend them. I am a retired Master Tech living in Heber City Utah. I worked for many years a various dealerships in SoCAl and was a certified Master Tech with the Advanced Engine Performance certification and I held an unlimited California Smog License for many years which qualified me to diagnose and repair failed vehicles without restrictions. Back in the early 80's I had a Dyno shop and we had a lot of 280Z customers and Cadillac customers with bad injectors. I tried testing & cleaning injectors but back then the equipment to "service" injectors did not exist.
Attached Files
File Type: pdf Injector Test Report046.pdf (527.9 KB, 1 views)
dstober is offline  
post #30 of 32 Old 02-20-2020, 09:19 AM Thread Starter
pinto_dave
Registered User
1996 ZJ 
 
Join Date: Oct 2015
Location: Boise
Posts: 135
I will definitely look into the injector testing through those guys, or rule out any injector issues. And be sure everything is up to snuff.

I did get around to checking the O2 sensor wiring harness and trace it out. Everything checked out good, wiggle test on connectors and wiring passed.

I found connector C132 on the firewall above the PCM was not tight and did not have the red locking tab locked into place, which may be part of the problem, but I'm sure its the reason for the random stall out that I had the other day when I had a passenger shut the door hard after getting in.

I'm thinking C131 not secured was largely contributing to the issues, as the fan shows the following circuits being passed through that connector:

1) Transmission control relay (for the transmission solenoid pack)
2)Both O2 sensor signal wires
3) Transmission relay for ignition
4) Fuel injector signal wires (passes through ASD relay)
5) Ignition Coil (passes through ASD relay)
6) Fuel pump module
7) Evap leak detection pump, solenoid, fuel pump relay
8) Starter relay


All of these point to the stalling issue, so I think that is resolved now. With the O2 sensor, fuel pump and injector signals routed through this connector, and it not being secured tightly, I believe it has a lot to do with the codes and health of the vehicle.

I haven't had the cat code come up again in the past 24 hours, which usually it was coming up after a 5 mile drive (driven 50 miles since securing it).

I have it at the dealership as we speak, and they are checking and setting the fuel sync for me to be sure that is in place, as well as possibly changing out the hitch.

1996 Grand Cherokee - 5.9 Limited Moss Green Poser

5.9 Limited Body and Interior Parts
pinto_dave is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome