5.2 engine cooling - Page 5 - JeepForum.com
 34Likes
Reply
 
LinkBack Thread Tools
post #61 of 72 Old 06-06-2021, 05:15 AM
PolkaPower
Registered User
 
PolkaPower's Avatar
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss
Posts: 23,776
Quote:
Originally Posted by HassZJ1998 View Post
yes it is the original, btw i marked one of the fan with white spray so i can see how fast it's going, yea it looks slow.

question, is it possible that the fan runs only on one speed ? or it is the relay that needs to be checked ? you know these 2 black relays under the edge of the right (passenger) side fender !! and if so how to check the relays ?

appreciate your help

It's possible that one speed only works. Relay or temp sender could be not working. I don't use the factory fan wiring so someone else will have to elaborate.


Sent from my iPhone using Tapatalk

HassZJ1998 likes this.
PolkaPower is offline  
Sponsored Links
Advertisement
 
post #62 of 72 Old 06-06-2021, 05:34 AM Thread Starter
HassZJ1998
Registered User
 
HassZJ1998's Avatar
1998 ZJ 
 
Join Date: May 2018
Location: Kuwait
Posts: 137
Quote:
Originally Posted by PolkaPower View Post
It's possible that one speed only works. Relay or temp sender could be not working. I don't use the factory fan wiring so someone else will have to elaborate.


Sent from my iPhone using Tapatalk
it's ok buddy, i appreciate it.

please take a look at my posts maybe you can help me, i always appreciate any feedback, thank you.
HassZJ1998 is offline  
post #63 of 72 Old 06-06-2021, 01:14 PM
hilljacknm
Registered User
1996 ZJ 
 
Join Date: Nov 2019
Location: Albuquerque
Posts: 123
Garage
Quote:
Originally Posted by PolkaPower View Post
You'll want to move those down as far as you can. I have the same set up and it blocked enough airflow to cause higher temperatures. I moved them down and cut out some sheet metal to create more surface area for the radiator and it helped quite a bit.



Sent from my iPhone using TapatalkAttachment 3991123



Cut a little out of my bumper also.....





It helps when driving. Figured I could always cut more out. Thanks for posting yours.
HassZJ1998 likes this.

1996 ZJ 5.2
Doug Thorley Headers, Kolak exhaust
B&M 70268 trans cooler
BFG KM3 30x9.50
hilljacknm is offline  
 
post #64 of 72 Old 06-06-2021, 05:55 PM
PolkaPower
Registered User
 
PolkaPower's Avatar
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss
Posts: 23,776
I'm eventually going to cut it all out and weld in something smaller and stronger but it'll be awhile. For now it cools well in summer with the bumper on.img_20190527_120118.jpg


Sent from my iPhone using Tapatalk
HassZJ1998 likes this.
PolkaPower is offline  
post #65 of 72 Old 06-07-2021, 07:53 PM
sldoaktree
Registered User
 
sldoaktree's Avatar
 
Join Date: May 2020
Location: las vegas
Posts: 59
Garage
Well this is what were lookin like now
Attached Thumbnails
DEDAF0B1-B47F-47EB-B9AC-ABCD66DDA213_1623113552367.jpg  
PolkaPower and HassZJ1998 like this.
sldoaktree is offline  
post #66 of 72 Old 06-07-2021, 10:32 PM
sldoaktree
Registered User
 
sldoaktree's Avatar
 
Join Date: May 2020
Location: las vegas
Posts: 59
Garage
Polka what front bumper is that btw? Who makes it?
sldoaktree is offline  
post #67 of 72 Old 06-07-2021, 10:59 PM
PolkaPower
Registered User
 
PolkaPower's Avatar
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss
Posts: 23,776
5.2 engine cooling

Quote:
Originally Posted by sldoaktree View Post
Polka what front bumper is that btw? Who makes it?

Home made. I copied this XJ bumper I liked. I still need to add the fairlead.img_20190918_175056-copy.jpg
img_20190918_175027-copy.jpg


Sent from my iPhone using Tapatalk
HassZJ1998 likes this.
PolkaPower is offline  
post #68 of 72 Old 06-08-2021, 01:12 AM Thread Starter
HassZJ1998
Registered User
 
HassZJ1998's Avatar
1998 ZJ 
 
Join Date: May 2018
Location: Kuwait
Posts: 137
Quote:
Originally Posted by PolkaPower View Post
Home made. I copied this XJ bumper I liked. I still need to add the fairlead.Attachment 3991477
Attachment 3991479


Sent from my iPhone using Tapatalk
looks great, job well done.
PolkaPower likes this.

please take a look at my posts maybe you can help me, i always appreciate any feedback, thank you.
HassZJ1998 is offline  
post #69 of 72 Old 06-08-2021, 01:15 AM Thread Starter
HassZJ1998
Registered User
 
HassZJ1998's Avatar
1998 ZJ 
 
Join Date: May 2018
Location: Kuwait
Posts: 137
Quote:
Originally Posted by sldoaktree View Post
Well this is what were lookin like now
wishing you the best buddy, massive job, thanks for sharing the photos

please take a look at my posts maybe you can help me, i always appreciate any feedback, thank you.
HassZJ1998 is offline  
post #70 of 72 Old 06-08-2021, 07:15 AM
sldoaktree
Registered User
 
sldoaktree's Avatar
 
Join Date: May 2020
Location: las vegas
Posts: 59
Garage
Thanks! Hope you get what you need and ill keep you updated on temps after i test run it..

Front bumper looks great wish you had a spare lol
HassZJ1998 likes this.
sldoaktree is offline  
post #71 of 72 Old 06-10-2021, 10:57 AM
sldoaktree
Registered User
 
sldoaktree's Avatar
 
Join Date: May 2020
Location: las vegas
Posts: 59
Garage
So driving in 90+ weather up a decent grade a/c full blast i stayed at 205 temp with windows down no a/c i was runnin 190… thanks for the help and pics… glad i didnt do a head gasket like someone was so sure of..
sldoaktree is offline  
post #72 of 72 Old 06-11-2021, 03:16 AM Thread Starter
HassZJ1998
Registered User
 
HassZJ1998's Avatar
1998 ZJ 
 
Join Date: May 2018
Location: Kuwait
Posts: 137
Quote:
Originally Posted by PolkaPower View Post
Quote:
Originally Posted by HassZJ1998 View Post
yes it is the original, btw i marked one of the fan with white spray so i can see how fast it's going, yea it looks slow.

question, is it possible that the fan runs only on one speed ? or it is the relay that needs to be checked ? you know these 2 black relays under the edge of the right (passenger) side fender !! and if so how to check the relays ?

appreciate your help

It's possible that one speed only works. Relay or temp sender could be not working. I don't use the factory fan wiring so someone else will have to elaborate.


Sent from my iPhone using Tapatalk

thanks again Polka, narrowing the places to start looking always helps.

I really appreciate it.
PolkaPower likes this.

please take a look at my posts maybe you can help me, i always appreciate any feedback, thank you.
HassZJ1998 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome