YJ Fuel Pump Replaced/ no power?? - JeepForum.com
Reply
 
LinkBack Thread Tools
post #1 of 22 Old 01-23-2015, 06:12 AM Thread Starter
RNJOE69
Registered User
1995 YJ Wrangler 
 
Join Date: Oct 2014
Location: Whitehall
Posts: 14
YJ Fuel Pump Replaced/ no power??

Hello to all. I replaced a failed in tank fuel pump on a 95 YJ now I have no power to the pump. I have run power to the tank portion of the harness and the pump will run and system will preasurize, but will not start. Have checked the relay @ Power box next to battery. Power to relay and relay checked, all ok but still no power to pump not even for the 3 seconds it should run before starting. Could the Autoshutdown relay/ circuit have something to do with it? where can I find a explanation of the function of this little item and caN i BYPASS IT?? THANKS IN ADVANCE FOR any HELP PROVIDED.
WHAT SHOULD HAVE BEEN A ONE DAY JOB HAS GONE ON A month. Rust & arthritic hands!

RNJOE69 is offline  
Sponsored Links
Advertisement
 
post #2 of 22 Old 01-23-2015, 06:57 AM
Mark05059
Registered User
1989 YJ Wrangler 
 
Join Date: Mar 2009
Location: quechee Vermont
Posts: 4,697
when you turn the key to on does the Check engine light come on for a few seconds?

1998 ZJ 5.2 Auto

1989 Wrangler Black Bone Stock 2.5l 5spd
/l , [____],
|---L--[]lllllll[]-
()_) ()_)==O=)_)
Mark05059 is offline  
post #3 of 22 Old 01-23-2015, 07:21 AM
flcracker
Registered User
1992 YJ Wrangler 
 
Join Date: Jun 2012
Location: Naples
Posts: 966
Can you jump the power across the relay (30 to 87) and get the pump to run?? If you can jump the relay, its in the control side of the relay (something in that circuit is messed up, wire, connection, ecu). If not, its in the fuel pump circuit itself....

edit, check all fuses before you get to involved with stuff

Not the sharpest bulb in the box....

My Jeep is possessed with the goal of making me lose my religion....
flcracker is offline  
 
post #4 of 22 Old 01-24-2015, 06:43 AM Thread Starter
RNJOE69
Registered User
1995 YJ Wrangler 
 
Join Date: Oct 2014
Location: Whitehall
Posts: 14
Well the "edit' you posted was the '****' as they say these days.. A fuse for the dash lights was blown a 15 amp one now the relays click and the pump engages, primes and she STARTS!! but won't stay running. So today its a recheck of fuses. Plenty of fuel pressure despite sounding like she is 'out of gas' before she dies..
Should I start a new thread?? .
Off topic.but hows the weather in Naples??

Last edited by RNJOE69; 01-24-2015 at 06:45 AM. Reason: afterthought
RNJOE69 is offline  
post #5 of 22 Old 01-24-2015, 07:38 AM
flcracker
Registered User
1992 YJ Wrangler 
 
Join Date: Jun 2012
Location: Naples
Posts: 966
Quote:
Originally Posted by RNJOE69 View Post
Well the "edit' you posted was the '****' as they say these days.. A fuse for the dash lights was blown a 15 amp one now the relays click and the pump engages, primes and she STARTS!! but won't stay running. So today its a recheck of fuses. Plenty of fuel pressure despite sounding like she is 'out of gas' before she dies..
Should I start a new thread?? .
Off topic.but hows the weather in Naples??
Warm but dark and cloudy today....

Troubleshooting 101, check the cheapest, easiest stuff first. I just went through a 4 week episode with finding a problem with similar symptoms but I wasn't lucky enough to have a blown fuse.... connection problems in plug to ecu here

Not the sharpest bulb in the box....

My Jeep is possessed with the goal of making me lose my religion....
flcracker is offline  
post #6 of 22 Old 01-26-2015, 07:27 AM
Que89YJ
Web Wheeler
2004 LJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 25,637
Stay with this thread. You replaced the fuel pump but there are a few things that relate to the pump. I strongly recommend you do a fuel pressure test to verify the rest of the fuel system. Check your fault codes and post what you get.
https://www.jeepforum.com/forum/f12/h...codes-1257145/
Que89YJ is offline  
post #7 of 22 Old 01-27-2015, 08:05 AM Thread Starter
RNJOE69
Registered User
1995 YJ Wrangler 
 
Join Date: Oct 2014
Location: Whitehall
Posts: 14
Fuel Press is @32 psi. no spark ended up to be a broken Ignition rotor. Replaced it but it won't stay running. It kicks over but will not continue to run.. will be doing TPS, Idel motor, Manifold Absolute Press and intake Manifold temp sensor.... I will advise on how that all turns out...
Thanks again guys!!
RNJOE69 is offline  
post #8 of 22 Old 01-27-2015, 08:51 AM
Que89YJ
Web Wheeler
2004 LJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 25,637
Wait! 32 is only part of it. You need to disconnect the vacuum line and see if pressure goes up. Then reconnect it and see if it hold pressure for 20 or more minutes. Each part is important. Check your fault codes next. I agree with the MAT sensor but you can check the sensors with a meter and save some $$$.
Que89YJ is offline  
post #9 of 22 Old 01-28-2015, 12:20 PM Thread Starter
RNJOE69
Registered User
1995 YJ Wrangler 
 
Join Date: Oct 2014
Location: Whitehall
Posts: 14
Codes came up with 13, and 33, and of course 55. here is where it gets crazy. Well NOW I have NO fuel press and with the key in the 'on' position: No fuel pump or press., no voltage at center post of Throttle Position Sensor, Vehicle Speed Serazynsor. Checked for a ground and it is GOOD. So today the washer bottle comes out to look at the computer so I can check continuity of mentioned sensors. As I look @ the schematic it sure looks like all these sensors are interdependent. Some weeks ago it started with the loss of my speedometer, I replaced the sending unit & it still did not work. That's when I learned to use my multi-meter. no power to unit and all downhill from there.
Thanks again for all the input...I will keep ya posted.
If you have any ideas I am all ears..and tools. LOL
RNJOE69 is offline  
post #10 of 22 Old 01-28-2015, 12:42 PM
flcracker
Registered User
1992 YJ Wrangler 
 
Join Date: Jun 2012
Location: Naples
Posts: 966
Oh snap.... that sounds familiar.... I had problems with the spread pin connectors in the ECU plug not making consistent contact and it only took 4 weeks and 10 pages

https://www.jeepforum.com/forum/f12/9...issue-2891249/

Not the sharpest bulb in the box....

My Jeep is possessed with the goal of making me lose my religion....
flcracker is offline  
post #11 of 22 Old 01-28-2015, 01:45 PM
Que89YJ
Web Wheeler
2004 LJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 25,637
X2 do what fl said.

Fault codes:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mean Max pics of everything:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

How to use Google to search the forum:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

No Start:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Que89YJ is offline  
post #12 of 22 Old 01-29-2015, 02:55 PM Thread Starter
RNJOE69
Registered User
1995 YJ Wrangler 
 
Join Date: Oct 2014
Location: Whitehall
Posts: 14
The Saga Continues

Well a little back peddling, Under the dash After testing all the fuses @ PDU (next to battery) along with ALL the relays..all was well So I went to the ignition switch which had power from the red wire (heavy gauge) with key off and on. The other side of the connection is the Yellow wire which should be hot with the key on...dead as a ISIS fighter in Syria should be. lol Key on or off its D-E-A-D. So the ignition switch is defective, (I hope!!!) What this has to do with my VSS(Vehicle Speed Sensor) going out a few months ago is beyond me. Oh since the fuel pump will NOT energize it is not possible to further test the pressure @ the fuel Rail...sure am learning a boat load of stuff!!

Last edited by RNJOE69; 01-29-2015 at 02:58 PM. Reason: fix spelling errors
RNJOE69 is offline  
post #13 of 22 Old 01-29-2015, 03:31 PM
flcracker
Registered User
1992 YJ Wrangler 
 
Join Date: Jun 2012
Location: Naples
Posts: 966
I learned more than I ever wanted to know about that part of the system when I was trying to figure mine out....

If the ignition switch is bad, it would prevent the ECU from powering up and starting fuel system.... Don't feel bad about vs thing yet, still haven't got my speedo working yet either....

Not the sharpest bulb in the box....

My Jeep is possessed with the goal of making me lose my religion....
flcracker is offline  
post #14 of 22 Old 01-29-2015, 09:50 PM
Que89YJ
Web Wheeler
2004 LJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 25,637
Yellow is the starter wire. Only hot in start.

Fault codes:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mean Max pics of everything:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

How to use Google to search the forum:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

No Start:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Que89YJ is offline  
post #15 of 22 Old 01-29-2015, 09:51 PM
Que89YJ
Web Wheeler
2004 LJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 25,637
Check power at 3/9. Follow sentinels directions on hard start no start

Fault codes:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mean Max pics of everything:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

How to use Google to search the forum:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

No Start:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Que89YJ is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome