Fuel Pump - JeepForum.com
 
LinkBack Thread Tools
post #1 of 4 Old 07-02-2020, 05:54 AM Thread Starter
itred
Registered User
1993 YJ Wrangler 
 
Join Date: Mar 2007
Posts: 29
Fuel Pump

Yj let me down, no fuel to injectors, no pump sound when turn key. checked connector at fuel pump, unplugged and plugged back in looked good. tried to start, cranks but wont fire. swapped horn and fuel pump relay and she fired right up. Horn also still works? could there have just been a loose connection at the relay? or can the fuel pumps be an intermittent problem. Anybody have any problems with the fuel pump relays and this issue? I'm a bit Leary to take her to far and having another fuel issue. Thanks

itred is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 07-02-2020, 06:44 AM
NHfireLJ
Web Wheeler
 
NHfireLJ's Avatar
1995 YJ Wrangler 
 
Join Date: Dec 2009
Location: Seacoast NH
Posts: 7,356
Could be all of the above.... you need to just keep trouble shooting.... clean all contacts of connections, and relays. wiggle them and wiring while its running...

Any codes? when you have a cold start, and turn the key to run does the CEL illuminate right away or is there a 30 second lag, and hearing the fuel pump kick on right away or a lag? if so, it may be the capacitors in the ECU.

AUDREY...95 YJ UNLIMITED LS
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


LUCY...2005 Unlimited "LJ" Rubicon Sahara #495
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
SOLD

BETTY...94, Stroker 4.6,35"s, SOLD


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
style intake
NHfireLJ is offline  
post #3 of 4 Old 07-02-2020, 07:31 AM
jtec
Web Wheeler
 
jtec's Avatar
2014 JK Wrangler 
 
Join Date: Oct 2017
Posts: 8,462
NOTE
The fuel pump will only have 12v for @3seconds if engine does not start! ! !

This makes testing voltage at fuel pump a little complicated; The fuel pressure is often checked first, then check and jump 12v at relay to energize fuel pump circuit,

When I see the price of OEM I think aftermarket.
When I see the quality of aftermarket I think OEM.
jtec is offline  
 
post #4 of 4 Old 07-02-2020, 08:20 AM Thread Starter
itred
Registered User
1993 YJ Wrangler 
 
Join Date: Mar 2007
Posts: 29
Thanks for the input. She is up and running now that i switched the horn and fuel relays, but the horn still works which leads me to believe it wasnt the relay itself but possible a bad connection in the fuse/ relay box. , so i don't know what the initial reason for no fuel was. Has anyone had any intermittent fuel pumps?
itred is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome