Engine died while driving and won't start back up. Pulling code 42. - JeepForum.com
Reply
 
LinkBack Thread Tools
post #1 of 57 Old 08-14-2015, 12:01 PM Thread Starter
rleff34
Registered User
1993 YJ Wrangler 
 
Join Date: Dec 2014
Posts: 89
93 YJ Engine died and won't start. No Start and Code 42.

The jeep has been driving fine, last night I cranked it up to leave Sonic, got half way around the parking lot/drive thru in 2nd gear feathering the gas and the engine just died. The starter engages, but it doesn't start up. OBD pulling code 42 which means ASD relay or fuel pump relay, to my understanding. (fuel guage reads.) Turning the key on I can hear what I think is the fuel pump turning on, so that could eliminate the fuel pump relay from causing the issue, am I correct? I have tried swapping both the ASD and fuel pump relays with the horn relay with no luck. I'm not sure where to proceed from here. Any help is much appreciated!


Last edited by rleff34; 08-14-2015 at 03:32 PM.
rleff34 is offline  
Sponsored Links
Advertisement
 
post #2 of 57 Old 08-14-2015, 01:08 PM
Que89YJ
Web Wheeler
2004 LJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 25,626
You need a meter to read some voltages. Make sure you are hearing the fuel pump kick on. Do you get the check engine light? For giggles jumper across the asd relay from 30/87 in the relay socket(Side of the relay show the numbers) with a short piece of wire and see if it starts.
Que89YJ is offline  
post #3 of 57 Old 08-14-2015, 02:52 PM Thread Starter
rleff34
Registered User
1993 YJ Wrangler 
 
Join Date: Dec 2014
Posts: 89
Quote:
Originally Posted by Que89YJ View Post
You need a meter to read some voltages. Make sure you are hearing the fuel pump kick on. Do you get the check engine light? For giggles jumper across the asd relay from 30/87 in the relay socket(Side of the relay show the numbers) with a short piece of wire and see if it starts.
Didn't get check engine light. I'll try to jump the relay... but I can hear the fuel pump turning on. And 12, 42, 55 only codes that pulled. What voltages do I need to read? I just don't know where to begin
rleff34 is offline  
 
post #4 of 57 Old 08-14-2015, 04:15 PM
Que89YJ
Web Wheeler
2004 LJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 25,626
Wait no cel. You need to check power on the ecu

Fault codes:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mean Max pics of everything:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

How to use Google to search the forum:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

No Start:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Que89YJ is offline  
post #5 of 57 Old 08-14-2015, 04:16 PM
Que89YJ
Web Wheeler
2004 LJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 25,626
Pins 3 and 9 on the ecu. Do you have a meter.

Fault codes:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mean Max pics of everything:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

How to use Google to search the forum:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

No Start:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Que89YJ is offline  
post #6 of 57 Old 08-14-2015, 04:21 PM
jsawduste
Web Wheeler
2006 YJ Wrangler 
 
Join Date: Jul 2006
Posts: 3,983
Quote:
Originally Posted by rleff34 View Post
last night I cranked it up to leave Sonic
There's your problem. Maybe it like Wendy`s better ?


Sorry no help from me but you got Que on it. Can`t do better then him.
jsawduste is offline  
post #7 of 57 Old 08-14-2015, 07:19 PM Thread Starter
rleff34
Registered User
1993 YJ Wrangler 
 
Join Date: Dec 2014
Posts: 89
Quote:
Originally Posted by Que89YJ View Post
Pins 3 and 9 on the ecu. Do you have a meter.
Yes, I have a meter, but I'm a little new to most of this so how do you tell which pins are which? Do I test this with the key on, engine off or do I test it with someone attempting to crank it? I appreciate your help.
rleff34 is offline  
post #8 of 57 Old 08-14-2015, 08:39 PM
Que89YJ
Web Wheeler
2004 LJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 25,626
This thread is what to check.
https://www.jeepforum.com/forum/f12/9.../topics/490788

This explains how to use Google a special way to get pics and info from just this forum

https://www.jeepforum.com/forum/f12/f...oogle-1003734/

Fault codes:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mean Max pics of everything:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

How to use Google to search the forum:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

No Start:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Que89YJ is offline  
post #9 of 57 Old 08-16-2015, 11:37 AM Thread Starter
rleff34
Registered User
1993 YJ Wrangler 
 
Join Date: Dec 2014
Posts: 89
Quote:
Originally Posted by Que89YJ View Post
This thread is what to check.
https://www.jeepforum.com/forum/f12/9.../topics/490788

This explains how to use Google a special way to get pics and info from just this forum

http://www.google.com/url?sa=t&sourc...gMxU4MhuIeNi8g
I'm waiting on rain to pass so I can push my jeep off the street and into my driveway for further testing.. but I was doing some testing as well as reading another post that you replied, and I have 12v in both the fuel pump relay and asd relay on pin 30 and you mentioned something about backfeeding? I will report back after I'm able to finish testing the ecm wiring harness. Damn wiper fluid reservoir.
rleff34 is offline  
post #10 of 57 Old 08-16-2015, 03:40 PM
Awesome
Registered User
 
Awesome's Avatar
1995 YJ Wrangler 
 
Join Date: Mar 2010
Location: Near Whacko
Posts: 3,866
Quote:
Originally Posted by rleff34 View Post
The jeep has been driving fine, last night I cranked it up to leave Sonic ...
Tails? Is it really you??

The 4th 5-seater YJ in the world.
Awesome is offline  
post #11 of 57 Old 08-16-2015, 06:08 PM Thread Starter
rleff34
Registered User
1993 YJ Wrangler 
 
Join Date: Dec 2014
Posts: 89
Quote:
Originally Posted by Que89YJ View Post
This thread is what to check.
https://www.jeepforum.com/forum/f12/9.../topics/490788

This explains how to use Google a special way to get pics and info from just this forum

https://www.jeepforum.com/forum/f12/f...oogle-1003734/
Ecu is getting power in pin 3 and 9 when key is on. Unless I've got a bad ground it's the ecu i think... I still don't understand how it would start like normal then die 20 seconds later and stop starting..
rleff34 is offline  
post #12 of 57 Old 08-16-2015, 06:32 PM
Que89YJ
Web Wheeler
2004 LJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 25,626
I don't think it's the ecu. Check it with your meter ground at pin 11.

Fault codes:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mean Max pics of everything:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

How to use Google to search the forum:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

No Start:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Que89YJ is offline  
post #13 of 57 Old 08-16-2015, 06:40 PM
jaycal3
Registered User
 
jaycal3's Avatar
1993 YJ Wrangler 
 
Join Date: Mar 2009
Posts: 1,304
Quote:
Originally Posted by Que89YJ
I don't think it's the ecu. Check it with your meter ground at pin 11.
Que89YJ, does all this sound eerily familiar??? Que is the man, he'll get you going no doubt!

93 YJ, 6 cyl,3.5" BDS,1" Prothane BL,1/2" booms, 33" Mickey Thompson MTZ on MT Beadlocks.

Do your part for Leukemia research - help find a cure.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

KCCO
jaycal3 is offline  
post #14 of 57 Old 08-16-2015, 07:31 PM Thread Starter
rleff34
Registered User
1993 YJ Wrangler 
 
Join Date: Dec 2014
Posts: 89
Quote:
Originally Posted by Que89YJ View Post
I don't think it's the ecu. Check it with your meter ground at pin 11.
Meter on ohms from pin 11 to battery ground terminal (disconnected) correct? I'm not very good at wiring.. but pin 11 and 12 read 0.0 when doing that but I'm not sure if I'm doing it right..
rleff34 is offline  
post #15 of 57 Old 08-16-2015, 07:37 PM
jaycal3
Registered User
 
jaycal3's Avatar
1993 YJ Wrangler 
 
Join Date: Mar 2009
Posts: 1,304
Quote:
Originally Posted by rleff34
Meter on ohms from pin 11 to battery ground terminal (disconnected) correct? I'm not very good at wiring.. but pin 11 and 12 read 0.0 when doing that but I'm not sure if I'm doing it right..
I believe you check pins 11 and 12 with pins 3 and 9...

93 YJ, 6 cyl,3.5" BDS,1" Prothane BL,1/2" booms, 33" Mickey Thompson MTZ on MT Beadlocks.

Do your part for Leukemia research - help find a cure.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

KCCO
jaycal3 is offline  
Reply

Tags
asd , fuel pump , relay , start problems , start-up

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome