1995 YJ front turn signals - JeepForum.com
 
LinkBack Thread Tools
post #1 of 5 Old 06-19-2019, 04:46 PM Thread Starter
Scott McIntyre
Registered User
 
Join Date: Sep 2018
Posts: 3
1995 YJ front turn signals

Hey, I was hoping someone can direct me in the right direction. My front turn signals wont flash, the parking light work. I have check fuses, cleaned the ground and replaced all the bulbs. The reats work but not the front. Any help is appreciated.

Scott McIntyre is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 06-19-2019, 07:17 PM
NHfireLJ
Web Wheeler
 
NHfireLJ's Avatar
1995 YJ Wrangler 
 
Join Date: Dec 2009
Location: Seacoast NH
Posts: 6,650
did you clean the bulb sockets? if grounds , bulbs and rears work, thats where I'd check next. Do your hazards work in the front?

AUDREY...95 YJ UNLIMITED
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


LUCY...2005 Unlimited "LJ" Rubicon Sahara #495
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
SOLD

BETTY...94, Stroker 4.6,35"s, SOLD


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
style intake
NHfireLJ is offline  
post #3 of 5 Old 06-19-2019, 07:31 PM Thread Starter
Scott McIntyre
Registered User
 
Join Date: Sep 2018
Posts: 3
No the hazards dont work in the front I'll see about cleaning the sockets.
Scott McIntyre is offline  
 
post #4 of 5 Old 06-20-2019, 06:06 AM
Siva283
Registered User
 
Siva283's Avatar
1993 YJ Wrangler 
 
Join Date: May 2011
Location: Baltimore
Posts: 4,142
Are they the correct bulbs. Should be 197 bulbs on the flares and 2157 in the driving lights on the grill. Pay attention to the grill the flares have a floating ground through the bulbs in the grill. You can also use 1157 bulbs in the grill but they arent as bright as the 2157 bulbs.

1995 YJ. 2 inch BDS Spring lift. 1 inch shackle lift. 1.25 inch JKS Body Lift 33x12.5x15's. Engo 10,000 pound winch.

Quote:
Originally Posted by Magnum View Post
I gave the Jeep the required offering of $$, sweat, and blood, and everything works fine now. -- Jim
Quote:
Originally Posted by ldso View Post
. It started with a $200 axle, and a few thousand dollars later I was done :)
Quote:
Originally Posted by Luuca View Post
diagnose the real issue before you start going all Obama on it - spending mad cash you'll need for other important things.

Ask me how I know...
Quote:
Originally Posted by Overhead View Post
this is also my second set of RC springs this year. I'd rather spend the money again and get something that will last.
Siva283 is offline  
post #5 of 5 Old 06-20-2019, 01:22 PM Thread Starter
Scott McIntyre
Registered User
 
Join Date: Sep 2018
Posts: 3
Appears the previous owner swapped the flare bulbs to cheap LEDs picking up new bulbs, one flare is working now the others still not working changed the flasher, and dash bulb as well. Cleaned the sockets so I am seeing progress.
Scott McIntyre is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome