1991 4.0 Loss of acceleration / power - Page 2 - JeepForum.com
Reply
 
LinkBack Thread Tools
post #16 of 21 Old 06-11-2012, 08:15 PM Thread Starter
MSUDawg
Registered User
1991  
 
Join Date: Jun 2010
Location: Orlando
Posts: 28
Quote:
Originally Posted by Que89YJ
Cracked exhaust manifold or loose bolts on it. Bad temp sensor near tstat.
I changed temp sensor near Tatar this morning. No help. I did install it when the engine was hot and Haynes says I should hav let it sit a few hours before changing it (not sure if that maters)

MSUDawg is offline  
Sponsored Links
Advertisement
 
post #17 of 21 Old 06-12-2012, 08:57 AM Thread Starter
MSUDawg
Registered User
1991  
 
Join Date: Jun 2010
Location: Orlando
Posts: 28
SOLVED!!!

My Mechanic, that charged me $135 for a fuel pressure test and new distributor cap / rotor (which I will never go back to) was wrong about the Catalytic Converter It was bad! So I replaced it and I have POWER AGAIN!

So you were right and my idiot mechanic was wrong! Thanks!
MSUDawg is offline  
post #18 of 21 Old 06-12-2012, 09:18 AM
pasinbuy
Registered User
1994 YJ Wrangler 
 
Join Date: Feb 2007
Location: florida
Posts: 3,900
To funny! I read your whole thread and when I reached the end I was going to tell you how to check your cat because the problem still sounded like the cat.

Makes me wonder how the mechanic thought the cat was fine. Maybe he looked at it, and then seeing that it looked OK, without testing gave it a OK. Lazy @ss mechanic.

Glad you found your problem.
pasinbuy is offline  
 
post #19 of 21 Old 06-12-2012, 09:36 AM
Que89YJ
Web Wheeler
2004 LJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 25,627
Me too Paisinbuy. I thought it was the cat. I wonder how the mechanic that said it was ok "tested" it.
Que89YJ is offline  
post #20 of 21 Old 06-12-2012, 09:49 AM
pasinbuy
Registered User
1994 YJ Wrangler 
 
Join Date: Feb 2007
Location: florida
Posts: 3,900
Quote:
Originally Posted by Que89YJ View Post
Me too Paisinbuy. I thought it was the cat. I wonder how the mechanic that said it was ok "tested" it.
From the sounds of it. He looked at it, saw the outside of the cat looked ok and passed it.
pasinbuy is offline  
post #21 of 21 Old 06-12-2012, 09:58 AM Thread Starter
MSUDawg
Registered User
1991  
 
Join Date: Jun 2010
Location: Orlando
Posts: 28
His idea was, if it didn't smell and it wasn't glowing red hot, it was fine.

I hope others learn from my Gullibility!!
MSUDawg is offline  
Reply

Tags
1991 yj , loss of power

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Massive power loss during acceleration. liveatibiza YJ Wrangler Technical Forum 14 06-14-2012 09:45 AM
loss of power under acceleration YJFreak YJ Wrangler Technical Forum 16 04-01-2011 11:37 PM
loss of power uphill/acceleration cryptostorm TJ Wrangler Technical Forum 10 08-10-2010 10:14 AM
Loss of power during acceleration SnatchBlock TJ Wrangler Technical Forum 5 06-15-2010 08:21 PM
Power/acceleration loss, especially uphill stripesthree YJ Wrangler Technical Forum 3 05-08-2010 11:26 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome