transmission issues - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 04-09-2017, 10:19 AM Thread Starter
H0lmes440
Registered User
 
Join Date: Apr 2017
Posts: 1
transmission issues

this is my issue....i have a 89 cherokee 4.0 AT i did a motor swap to a 4.0 inline 6 out of a 95 jeep wrangler, she starts and runs beautiful accept she wont go in drive 1st2nd no problem 3rd same good but in drive nothing she wont move i have to drop to 1st2nd and manually shift till 3rd put her in drive she goes but no power she wont even kick down a gear to gain speed....ive check fluid, linkage, drive line, torque converter, now keep in mind its a 89 transmission on a 95 block if that makes a difference

H0lmes440 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 04-10-2017, 05:23 AM
CJ7-Tim
Real Jeeps have dents
 
CJ7-Tim's Avatar
2000 XJ Cherokee 
 
Join Date: Apr 2002
Location: out in the garage - Minneapolis
Posts: 28,572
The Cherokee AW-4 AT transmission is controlled by a separate computer controller. The symptoms suggest that the trans is fine, but that there is a wiring issue such as failed/damaged wires or wire plugs, something is unplugged, or the Transmission Control Unit computer is faulty.


Did you adjust the kickdown cable using the Service Manual instructions ?

.
“When the people find that they can vote themselves money, that will herald the end of the Republic.”

- Benjamin Franklin
CJ7-Tim is offline  
post #3 of 3 Old 04-10-2017, 08:15 AM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 12,148
Look here and make sure both of those plugs are connected.

http://cruiser54.com/?p=58

Also, if you missed hooking up the grounds at the dipstick tube stud, or it's heavily painted, that could cause issues.

http://cruiser54.com/?p=19

If you own a Renix Jeep, you must check this out:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My Jeep technical photos:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cruiser54 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome