P1698 no bus message from transmission control module - JeepForum.com
 
LinkBack Thread Tools
post #1 of 4 Old 04-20-2012, 11:27 AM Thread Starter
me77
Registered User
1999 XJ Cherokee 
 
Join Date: Apr 2012
Location: elktom
Posts: 5
P1698 no bus message from transmission control module

Sometimes, it seems randomly, when I pull out of my boyfriends driveway and get up to between 40 and 50 mph my check engine light comes on. It only happens after I pull out of his driveway and nowhere else. When we check it, it says p1698 no bus message from transmission control module. The car appears to be running just like normal but the light is coming on more frequently. Does anyone know what this means? We were thinking there mitt be a lose connection somewhere, but where? I have a 99' jeep cherokee. Thanx for anyones help!

me77 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 04-20-2012, 02:23 PM
CCKen
Web Wheeler
 
CCKen's Avatar
1999 XJ Cherokee 
 
Join Date: Jul 2011
Location: Canton
Posts: 3,548
1st, check the ground terminals at G101 (see pic-note tht the TCM is grounded here.). Check for evidence of corrosion and security of the nuts. If corrosion is suspected, remove the nuts and clean the terminal ends and reassemble with a light coat of "Tune Up Grease" on the terminals. Torque the nuts to 110 in./lbs. Make sure the wires are not chaffing on the coil mount.



Next, make sure the harness connector on the TCM is secure. If you are inclined, remove the connector and inspect the pins and cavities for corrosion (black stuff). Clean with CRC Electronic Cleaner and reassemble carefully. Give the harness wires a gentle wiggle for good measure.

See if there are any other pending codes using a scanner. Erase/delete P1698.

Check back.
CCKen is offline  
post #3 of 4 Old 04-20-2012, 08:52 PM Thread Starter
me77
Registered User
1999 XJ Cherokee 
 
Join Date: Apr 2012
Location: elktom
Posts: 5
Will try! Thank you very very much
me77 is offline  
 
post #4 of 4 Old 04-26-2012, 08:47 PM Thread Starter
me77
Registered User
1999 XJ Cherokee 
 
Join Date: Apr 2012
Location: elktom
Posts: 5
It seems to be working so far thank you very much
me77 is offline  
Reply

Tags
No bus , p1698

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
TRANSMISSION OVER TEMP message after trailer wiring install grandebob XJ Cherokee Technical Forum 7 08-29-2011 10:39 AM
Transmission Control Module & P1698 xjarchaeologist XJ Cherokee Technical Forum 1 06-14-2008 12:20 AM
Where is my ABS Control Module? Tony90 XJ Cherokee Technical Forum 7 09-26-2007 02:37 PM
How does the TCM (Transmission Control Module) work? 1BadRS XJ Cherokee Technical Forum 4 12-29-2004 04:02 PM
transmission control module myah XJ Cherokee Technical Forum 6 08-26-2002 07:34 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome