O2 Sensor Help - JeepForum.com
 
LinkBack Thread Tools
post #1 of 15 Old 03-06-2013, 08:22 PM Thread Starter
StevenXJ
Registered User
2000 XJ Cherokee 
 
Join Date: Mar 2009
Location: New Jersey
Posts: 115
O2 Sensor Help

I went to recently replace the O2 sensor on my Jeep and found out that apparently the person before me used a universal or something and cut the connector for the sensor from the harness. Is there any way to replace that so I can use the NTK sensor?

StevenXJ is offline  
Sponsored Links
Advertisement
 
post #2 of 15 Old 03-07-2013, 08:49 AM
CCKen
Web Wheeler
 
CCKen's Avatar
1999 XJ Cherokee 
 
Join Date: Jul 2011
Location: Canton
Posts: 3,548
Here's some data from the NTK/NGK website concerning universal O2S installations. Hope it helps in your case.

http://www.ngksparkplugs.com/images/...t_11-16-04.pdf
CCKen is offline  
post #3 of 15 Old 04-29-2013, 07:48 AM Thread Starter
StevenXJ
Registered User
2000 XJ Cherokee 
 
Join Date: Mar 2009
Location: New Jersey
Posts: 115
Unfortunately that did not help.
StevenXJ is offline  
 
post #4 of 15 Old 04-29-2013, 08:24 AM
CCKen
Web Wheeler
 
CCKen's Avatar
1999 XJ Cherokee 
 
Join Date: Jul 2011
Location: Canton
Posts: 3,548
I think your only hope is to get one from a junk yard or a Cherokee being boned out by owner (Craigslist).
CCKen is offline  
post #5 of 15 Old 04-29-2013, 08:26 AM
Max78
Registered User
1992 XJ Cherokee 
 
Join Date: Jun 2009
Location: Tucson,AZ
Posts: 566
The PO cut your original connector off the harness? If that's the case head down to a local junkyard with some wire cutters.

92 Cherokee - All nude and in need of some tlc!
Max78 is offline  
post #6 of 15 Old 04-29-2013, 08:29 AM
EvolutionXJ
Registered User
 
EvolutionXJ's Avatar
1994 XJ Cherokee 
 
Join Date: Mar 2013
Location: Henrico
Posts: 69
Well that sucks. Yea head to a junkyard. Clip the connector off and if you couldnt guess what's next. Sauder that bad boy on
EvolutionXJ is offline  
post #7 of 15 Old 04-29-2013, 10:50 AM Thread Starter
StevenXJ
Registered User
2000 XJ Cherokee 
 
Join Date: Mar 2009
Location: New Jersey
Posts: 115
Does anyone know the year ranges that I can cut the wires off? Or should I just get a 2000 like mine?
StevenXJ is offline  
post #8 of 15 Old 04-29-2013, 10:57 AM
CCKen
Web Wheeler
 
CCKen's Avatar
1999 XJ Cherokee 
 
Join Date: Jul 2011
Location: Canton
Posts: 3,548
Quote:
Originally Posted by StevenXJ View Post
Does anyone know the year ranges that I can cut the wires off? Or should I just get a 2000 like mine?
The connectors are all the same but the wire colors differ if not a 2000. Get them from a '98 + Cherokee XJ. Just let us know what you get so the wire colors can be matched up.

Do you have two upstream O2S's and two downstream, or just one up and one down?
CCKen is offline  
post #9 of 15 Old 04-29-2013, 11:10 AM Thread Starter
StevenXJ
Registered User
2000 XJ Cherokee 
 
Join Date: Mar 2009
Location: New Jersey
Posts: 115
2&2.
StevenXJ is offline  
post #10 of 15 Old 05-06-2013, 11:31 PM Thread Starter
StevenXJ
Registered User
2000 XJ Cherokee 
 
Join Date: Mar 2009
Location: New Jersey
Posts: 115
I got the wiring out of an 01 Cherokee. I will be putting it in this weekend. It looks to be the same colors.
StevenXJ is offline  
post #11 of 15 Old 05-12-2013, 02:08 PM Thread Starter
StevenXJ
Registered User
2000 XJ Cherokee 
 
Join Date: Mar 2009
Location: New Jersey
Posts: 115
I put the new connector on (same colors) and bought a NTK sensor and put it in. I started it up and it was still throwing the same code (P0137) I did a lot of research on it and everything is ok, so now I am stuck. Any ideas?
StevenXJ is offline  
post #12 of 15 Old 05-12-2013, 03:01 PM
CCKen
Web Wheeler
 
CCKen's Avatar
1999 XJ Cherokee 
 
Join Date: Jul 2011
Location: Canton
Posts: 3,548
Quote:
Originally Posted by StevenXJ View Post
I put the new connector on (same colors) and bought a NTK sensor and put it in. I started it up and it was still throwing the same code (P0137) I did a lot of research on it and everything is ok, so now I am stuck. Any ideas?
What is okay?
CCKen is offline  
post #13 of 15 Old 05-12-2013, 03:14 PM Thread Starter
StevenXJ
Registered User
2000 XJ Cherokee 
 
Join Date: Mar 2009
Location: New Jersey
Posts: 115
All the wires check ok. Sorry.
StevenXJ is offline  
post #14 of 15 Old 05-13-2013, 05:31 AM
CCKen
Web Wheeler
 
CCKen's Avatar
1999 XJ Cherokee 
 
Join Date: Jul 2011
Location: Canton
Posts: 3,548
Quote:
Originally Posted by StevenXJ View Post
All the wires check ok. Sorry.
Which O2S is it?
CCKen is offline  
post #15 of 15 Old 05-13-2013, 11:00 AM Thread Starter
StevenXJ
Registered User
2000 XJ Cherokee 
 
Join Date: Mar 2009
Location: New Jersey
Posts: 115
Bank 1 Sensor 2.
StevenXJ is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome