middle of the pulley system pouring out coolant randomly - JeepForum.com
 
LinkBack Thread Tools
post #1 of 5 Old 10-15-2015, 04:25 PM Thread Starter
MattGoetz
Registered User
 
Join Date: Sep 2013
Posts: 1
Xj middle of the pulley system pouring out coolant randomly

Hey I need help so I was driving around yesterday and all was good but as soon as I pulled into my driveway the engine started pouring our water but was not overheating. So I tried to see where the leak was coming from and filled the radiator back up and started it, again it was not leaking right away but once it hit 190-200 it started pouring out coolant from the middle of the pulley system, could not see exactly where it was coming from. Does anyone know why this may be happening or whats broken??

MattGoetz is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 10-15-2015, 06:33 PM
lsmurphy
Registered User
 
Join Date: Aug 2010
Location: Parrottsville
Posts: 560
water pump
lsmurphy is offline  
post #3 of 5 Old 10-15-2015, 07:32 PM
shooptube
Big Brother
 
shooptube's Avatar
1997 XJ Cherokee 
 
Join Date: May 2013
Location: Southgate
Posts: 4,043
Garage
Quote:
Originally Posted by lsmurphy View Post
water pump
X2 Water pump weap hole. It's a factory made sign that your water pump pulley seal is going bad.

Quote:
Originally Posted by Luke95 View Post
I am Moar low.
Build Thread:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Instagram:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
shooptube is offline  
 
post #4 of 5 Old 10-16-2015, 10:12 PM
sk8rgrl
Registered User
2000 XJ Cherokee 
 
Join Date: Feb 2013
Posts: 46
Quote:
Originally Posted by lsmurphy View Post
water pump
x3
sk8rgrl is offline  
post #5 of 5 Old 10-17-2015, 07:36 AM
Ciphery
Registered User
2001 XJ Cherokee 
 
Join Date: Sep 2015
Location: Port-Sydney
Posts: 223
Ya...the water pump is turned by a pully and when the bearings in the pump start to go they leak from a drain hole in the side of the pump housing, this way you are alerted to this happening and change the pump before it seizes and leaves you stranded in the back country.....although the therostat housing is also right above the water pump housing and are subject to corrosion. Once the thermost hits 190-200F it opens to left antifreeze circulate in the system...if the housing has a hole in it it will then spray every where..could be a heater core or rad hose too.

My sugestion is to replace both the water pump and the thermostat housing, squeeze the hoses and if you hear them creak or crunch or if the ends are cracked and weather checked replace them too.
All these things might not need replacing but they should be inspected to determine.

While you are at it replace the antifreeze with new fresh stuff as the old stuff will be full of chewed up bearing bits, rust, forgin particulates and be a bad Ph balance that supports electrolytic corrosion that will imediately start attacking your new water pump/Tstat housing etc
Ciphery is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome