Jeep Cooling System Issue - JeepForum.com
 
LinkBack Thread Tools
post #1 of 2 Old 08-29-2016, 12:26 PM Thread Starter
HolesNMyPockets
Registered User
 
Join Date: Aug 2016
Posts: 2
Jeep Cooling System Issue

Hey there, I have been having a lot of issues with my 98 Cherokee. Bought it a year ago this month and as I was driving it home for the first time she overheated and proceeded to pour a Niagara Falls of coolant from underneath my front end. This struck me as odd because the water pump and radiator had been replaced that year. Took it to the mechanic and he said nothing was wrong (bull crap). Anyways I kept having issues with her over heating and spitting coolant out from underneath the radiator cap, finally I replaced the thermostat and the radiator cap twice. By this time the weather is already cooled down and she was running at the average normal 210. Winter hits and I realize my heater doesn't work (it was a very cold drive to and from work). Summer hit this year and I realized I had a new issue with my cooling system. Found a leak around the lower radiator hose. Replaced the hose last night and realized whoever had replaced it before me had put it on BACKWARDS! Put it on correctly this time did a radiator flush at the same time as well and thought I'm golden. Wrong. Got home after fixing it she was still spitting coolant out from underneath the radiator cap. Did some research and found someone who had the exact same issue and found out that their overflow tube was clogged. So in high hopes I replaced it today and cranked my A/C up to see if it worked. Nope. So now I am at a loss. Someone give me any pointers please. The only thing I'm dreading is that the radiator is shot.

Here is a list of everything that has been replaced on it by me since last August 2015:
Thermostat 2x
Radiator cap 2x
Control Temperature Sensor
Lower Radiator Hose
Overflow Tube

P.S.
I live Phoenix, AZ. Temps of 110 in summer.

HolesNMyPockets is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 08-29-2016, 12:55 PM
Domengo
Registered User
 
Join Date: Oct 2015
Location: Albany
Posts: 287
This should probably be moved to the XJ technical forum.

I can fix anything. Usually because I've broken it before.
Domengo is offline  
Reply

Tags
cooling system , issues , over heating , problems , radiator

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome